summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-01-29 20:35:52 -0600
committerSam James <sam@gentoo.org>2023-01-31 17:25:10 +0000
commitc4f1c9917bbdce3a08fe5fe0e666315951fd9b64 (patch)
tree16fcf03999f1fa191bdbaf6cf80291ca159f0d01 /dev-python/gentoo-common
parentdev-python/basho-erlastic: EAPI 8, PEP517, py3.11 (diff)
downloadgentoo-c4f1c9917bbdce3a08fe5fe0e666315951fd9b64.tar.gz
gentoo-c4f1c9917bbdce3a08fe5fe0e666315951fd9b64.tar.bz2
gentoo-c4f1c9917bbdce3a08fe5fe0e666315951fd9b64.zip
dev-python/gentoo-common: add 1, drop 0
Add info on exiting and re-entering the venv. Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29336 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/gentoo-common')
-rw-r--r--dev-python/gentoo-common/gentoo-common-1.ebuild (renamed from dev-python/gentoo-common/gentoo-common-0.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/gentoo-common/gentoo-common-0.ebuild b/dev-python/gentoo-common/gentoo-common-1.ebuild
index 58e23e58f72d..c09fd9e6d2b8 100644
--- a/dev-python/gentoo-common/gentoo-common-0.ebuild
+++ b/dev-python/gentoo-common/gentoo-common-1.ebuild
@@ -26,5 +26,12 @@ src_install() {
python -m venv /path/to/venv
. /path/to/venv/bin/activate
pip install mypackage
+
+ To exit the virtual environment, run:
+
+ deactivate
+
+ The virtual environment is not deleted, and can be re-entered by
+ re-sourcing the activate file.
EOF
}