summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-14 18:51:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-14 22:29:51 +0100
commit4ae30ca39d6541e68b6b65c9f6e409c4ac0e7443 (patch)
tree4a97361eeb8caf4ce23cf72653e9ceb190174d63 /dev-python/fs
parentdev-python/nbformat: Bump to 5.1.1 (diff)
downloadgentoo-4ae30ca39d6541e68b6b65c9f6e409c4ac0e7443.tar.gz
gentoo-4ae30ca39d6541e68b6b65c9f6e409c4ac0e7443.tar.bz2
gentoo-4ae30ca39d6541e68b6b65c9f6e409c4ac0e7443.zip
dev-python/fs: Bump to 2.4.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/Manifest1
-rw-r--r--dev-python/fs/fs-2.4.12.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
index 5c4f7750914d..fc730ee9d102 100644
--- a/dev-python/fs/Manifest
+++ b/dev-python/fs/Manifest
@@ -1 +1,2 @@
DIST fs-2.4.11.tar.gz 163986 BLAKE2B 953e50da7002512029c0a1a8e7fe8be3a7c31fc48e2c66f0fe7d71dc908aab734f724e09c16074c3e4cdd86c9c2e1a847aa21176af07311012090375a3a6808e SHA512 fe4596bf213f9b1721cd3c665e6af180d6617eea07afbaa9d83847dc3f7dfe64bca16c8ccb337d48bbb49bf0d2fef90903e3c4aecc63f61faac6a2b6f6c59cf6
+DIST fs-2.4.12.tar.gz 165536 BLAKE2B 9212ffc1f2d5c315091116770e045e4c5365690d61ca34c3f4a9ce82764c4ba5be6af886e62c8baaf57ab461539a02aa042d50a9dcf314b0894710953571d37f SHA512 8b4727ea21cb9e1b69e31688c46f0732bb1536490549e353c1f88ab0c794b867c5212d1003b094cc86f562108ab4a7ee9dbc7e9aa5dc1349371de583277eb93d
diff --git a/dev-python/fs/fs-2.4.12.ebuild b/dev-python/fs/fs-2.4.12.ebuild
new file mode 100644
index 000000000000..3c3ba7eba881
--- /dev/null
+++ b/dev-python/fs/fs-2.4.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+MY_PN="pyfilesystem2"
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ https://pypi.org/project/fs/
+ https://docs.pyfilesystem.org
+ https://www.willmcgugan.com/tag/fs/
+"
+# Tests from the PyPI tarball are broken
+# https://github.com/PyFilesystem/pyfilesystem2/issues/364
+SRC_URI="https://github.com/PyFilesystem/pyfilesystem2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}