summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 18:41:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 18:45:32 +0100
commitd569483a23e1fba5027ad56cedf3872c44e3258c (patch)
treed52c6ce80f6c183579b093d75ff1d2777ae19a11 /dev-python/flask-debug/flask-debug-0.4.3-r2.ebuild
parentdev-python/ntplib: EAPI 8, PEP517, py3.11 (diff)
downloadgentoo-d569483a23e1fba5027ad56cedf3872c44e3258c.tar.gz
gentoo-d569483a23e1fba5027ad56cedf3872c44e3258c.tar.bz2
gentoo-d569483a23e1fba5027ad56cedf3872c44e3258c.zip
dev-python/flask-debug: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-debug/flask-debug-0.4.3-r2.ebuild')
-rw-r--r--dev-python/flask-debug/flask-debug-0.4.3-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/flask-debug/flask-debug-0.4.3-r2.ebuild b/dev-python/flask-debug/flask-debug-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..267f6fbbd700
--- /dev/null
+++ b/dev-python/flask-debug/flask-debug-0.4.3-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="Flask-Debug-${PV}"
+DESCRIPTION="Flask extension that displays various debugging insights during development"
+HOMEPAGE="
+ https://github.com/mbr/Flask-Debug/
+ https://pypi.org/project/Flask-Debug/
+"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/Flask-Debug/pull/2
+SRC_URI="
+ https://github.com/mbr/Flask-Debug/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster