summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-17 16:16:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-17 21:01:21 +0200
commita8d6ba427348eeff6a4d0056d7b218a33573ac20 (patch)
treeee0716d0184b7b98cfbdb5f9ff291d5ed62300c2 /dev-python/executing
parentdev-python/lxml: Bump to 4.6.0 (diff)
downloadgentoo-a8d6ba427348eeff6a4d0056d7b218a33573ac20.tar.gz
gentoo-a8d6ba427348eeff6a4d0056d7b218a33573ac20.tar.bz2
gentoo-a8d6ba427348eeff6a4d0056d7b218a33573ac20.zip
dev-python/executing: Bump to 0.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-0.5.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 6665f9a34532..46494dcd2b29 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1 +1,2 @@
DIST executing-0.5.2.gh.tar.gz 303118 BLAKE2B e3b0ee22791a7fc4b378cf9f0c4640b4971ebd772d95a5d8d0abd25959c53eede5c61e4807abd4be38b9e14d0e3ab9083941ace7f59f0b6358c68b2e85291193 SHA512 2487dbb95240553f9bb7e1249af42e83be7db8cfa8a8c0569c22bfad48add9eddf903a4f365e3a6409e5208bef0d32893abb0c4dc5a93782c3b33125b091ef54
+DIST executing-0.5.3.gh.tar.gz 303234 BLAKE2B cb9de0492c4aa31b53310abf65d97df888278671fbf24e5dc2f3f4b00fd22d233fae2265bffe240c092c5b67bfca1e69ec1c4eaa937a0d4c90bedced1f156e2a SHA512 faf591de8e6354300fb572065bda304c3cbc529725b4044ad4f4ca1f86d892da21598ba7245059824e27894937d46e4ef9ef5962a9d7dff78e4144a3e0e6b388
diff --git a/dev-python/executing/executing-0.5.3.ebuild b/dev-python/executing/executing-0.5.3.ebuild
new file mode 100644
index 000000000000..bdeaacb0be41
--- /dev/null
+++ b/dev-python/executing/executing-0.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ # Kill off useless wheel dep
+ sed -i -e 's/wheel; //' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ pytest -vv tests/test_pytest.py || die "Tests failed with ${EPYTHON}"
+}