summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-07-12 16:46:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-07-12 16:47:01 -0500
commited7e8f7c8bb4340736b34e323a330b1452f1224b (patch)
treebe412233fe4d2a4eb1c443db1bbe268807763c9d /dev-python/djangorestframework
parentapp-shells/rush: Bump to version 2.1 (diff)
downloadgentoo-ed7e8f7c8bb4340736b34e323a330b1452f1224b.tar.gz
gentoo-ed7e8f7c8bb4340736b34e323a330b1452f1224b.tar.bz2
gentoo-ed7e8f7c8bb4340736b34e323a330b1452f1224b.zip
dev-python/djangorestframework: 3.9.4 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.9.4.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index f0ddcff8a374..417da5aacefc 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1 +1,2 @@
DIST djangorestframework-3.9.2.tar.gz 785546 BLAKE2B b00e502a483894bfcebb9075a2534a68d0c48093b60482dfd2fd3b5653731ba5d535259451fcdd2f25f16832ec9e5a6b5e13b5e43095f770b88a0f251525a69d SHA512 cf3b23de7b27bca082df571a2cfcb1c593bebd36830b60238a2efa794ded762b22444a00885acac7d97db393943063a9f7a81e9dd32628afa7f1308008520a76
+DIST djangorestframework-3.9.4.tar.gz 779306 BLAKE2B 9ae955cf0145ad8b80b65d8b6d8f0b947e0e11ecb1b52939a1fd4d209d48d84a4d756d979596180c63f6caf25ff796503b0b3cc8237ec1bbf2d1787fae5a2863 SHA512 bfa269b1ca95c1d35d97f3fcdcf821778f2c2ba14ce79288b776ecff369922603ba9a2292a59ca8ad263eb3eef675420a2bb2e609e11e53e503a78bd365b2913
diff --git a/dev-python/djangorestframework/djangorestframework-3.9.4.ebuild b/dev-python/djangorestframework/djangorestframework-3.9.4.ebuild
new file mode 100644
index 000000000000..7ec25886c67a
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.9.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"