summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-26 05:01:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-26 05:01:52 +0100
commit65565fc4dc6ad12a411ada32236761a388083cc3 (patch)
tree8a8be94bf477ca2ac77cb13320c85c50e02d9786 /dev-python/django-timezone-field
parentdev-python/ytmusicapi: Remove old (diff)
downloadgentoo-65565fc4dc6ad12a411ada32236761a388083cc3.tar.gz
gentoo-65565fc4dc6ad12a411ada32236761a388083cc3.tar.bz2
gentoo-65565fc4dc6ad12a411ada32236761a388083cc3.zip
dev-python/django-timezone-field: Bump to 6.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index a500e3683d3b..74cd8e52b622 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1 +1,2 @@
DIST django-timezone-field-6.0.1.gh.tar.gz 35800 BLAKE2B f3b46970bbe234f786988d8c71a016c382ea3d82b798eaf78e685f86a80b3ebd3ee495d0f0230afb84f594b443548d9bc1e8891ea37c08be478bab388edfd70b SHA512 e6d1631af6a4d93f2fae236cf12d8fda15dfd6d70ee01c496364c3e5e141fff2bb5982f607adf474617a86b9f0f611306a17d1d892556a087424110ee3de541d
+DIST django-timezone-field-6.1.0.gh.tar.gz 36029 BLAKE2B 5177b440e0537fbde12e0dd4bf92e65c983996f7ef1393212b0f4c24efecfc0d4d24e1bbc8447295b565d8b9921c0c05f6cc4baa11db3ccc9b60c33c48e76fb2 SHA512 b070e55a2a5196de1fcae4bd19979caf9d84c234a4e379d82dab843541cf99a0acced9a6996e35afe6b40d1bf737d522d34b91df10596e7365f85cfbe0597015
diff --git a/dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild
new file mode 100644
index 000000000000..a51019e8569a
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ <dev-python/django-6[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}