summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-19 22:50:26 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-19 22:50:44 +0200
commit4e51f20fc9cfbc5e53656f4b575cc0406125a3d2 (patch)
tree2eddb5fc8fc6e92b277cdf517cd6dc1492738936 /dev-python/django-prometheus
parentdev-python/fonttools: add 4.28.5 (diff)
downloadgentoo-4e51f20fc9cfbc5e53656f4b575cc0406125a3d2.tar.gz
gentoo-4e51f20fc9cfbc5e53656f4b575cc0406125a3d2.tar.bz2
gentoo-4e51f20fc9cfbc5e53656f4b575cc0406125a3d2.zip
dev-python/django-prometheus: add 2.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/django-prometheus')
-rw-r--r--dev-python/django-prometheus/Manifest1
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index 21085c684db9..eb1086f1ce59 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1 +1,2 @@
DIST django-prometheus-2.1.0.tar.gz 24615 BLAKE2B 381aa345fac29e71e2b883fb485dce1d6ca3f13fc863d6ca9a62d5cd8f605f8cca727fbc3a3946e707d80f89d7fbaf544610cfb4857a45bc3dc13eeb22aeb4d6 SHA512 0c102467b99df409e31f99fb77d16558bd01c9c11f04ac0f80b59e486bc6e03979e16785083980c43ee3caad26b7a6bf618f9592fcca788ec2793a30d6b44241
+DIST django-prometheus-2.2.0.tar.gz 24995 BLAKE2B db79cbed99d4d5cb7d9ce22dfee69914a63373417b176b4311406f9a1fdcada16447d6ec8cb19ebd14789f520aa1d5755aace824e5462611f81a0cc688566f19 SHA512 a72c8345f220799ad0709e0e73912229267b5e01fc67ae7f647e53ccf7c7e170ad2456c81070a002dc411e840b1129d55719a7aa891b4dabe262837c8c7b3db5
diff --git a/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild b/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild
new file mode 100644
index 000000000000..79c9b92ea2d7
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library to export Django metrics for Prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}