summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-09 11:27:59 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-09 11:28:34 +0200
commit5d781c5d6d793215365460e4e2c6d18208ac74ea (patch)
tree72ad438324823c05113251c616e35fa3851dc74b /dev-python/django-debug-toolbar
parentdev-util/buildbot-wsgi-dashboards: enable py3.11 (diff)
downloadgentoo-5d781c5d6d793215365460e4e2c6d18208ac74ea.tar.gz
gentoo-5d781c5d6d793215365460e4e2c6d18208ac74ea.tar.bz2
gentoo-5d781c5d6d793215365460e4e2c6d18208ac74ea.zip
dev-python/django-debug-toolbar: new package, add 3.8.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild20
-rw-r--r--dev-python/django-debug-toolbar/metadata.xml12
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
new file mode 100644
index 000000000000..65939af67ea9
--- /dev/null
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -0,0 +1 @@
+DIST django-debug-toolbar-3.8.1.gh.tar.gz 269449 BLAKE2B e93da38cdb6aa160dab65816858b1f7ca532ad22617e1859669fc508472086a93807aa874fde92ef95e6e33268a2f14de19d1498a15ca92ec89a9f8b3bf2a323 SHA512 4fa7b3fa3f9767cf1edba26c9de625675bcb1bafcb6d88d7ab95c331da6865f5c3cdb25848a6d2f4befdf9b2e65db4123b496f06a1b2e39eb3ee71f0c3384d26
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild
new file mode 100644
index 000000000000..8937c1b48d37
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-3.8.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="https://pypi.org/project/django-debug-toolbar/"
+SRC_URI="https://github.com/jazzband/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Need some effort to do that
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-debug-toolbar/metadata.xml b/dev-python/django-debug-toolbar/metadata.xml
new file mode 100644
index 000000000000..fd28509eea42
--- /dev/null
+++ b/dev-python/django-debug-toolbar/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-debug-toolbar</remote-id>
+ <remote-id type="github">jazzband/django-debug-toolbar</remote-id>
+ </upstream>
+</pkgmetadata>