summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-04-17 10:31:34 -0400
committerCraig Andrews <candrews@gentoo.org>2020-04-17 10:43:22 -0400
commit2b1280d03f7973b6c238f7de307e4105ff754003 (patch)
tree7602063785e57ef78e56facdc03ccffa5408ed26 /dev-python/distro
parentdev-python/distro: Python 3.8 compatibility (diff)
downloadgentoo-2b1280d03f7973b6c238f7de307e4105ff754003.tar.gz
gentoo-2b1280d03f7973b6c238f7de307e4105ff754003.tar.bz2
gentoo-2b1280d03f7973b6c238f7de307e4105ff754003.zip
dev-python/distro: 1.3.0 version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/distro')
-rw-r--r--dev-python/distro/Manifest1
-rw-r--r--dev-python/distro/distro-1.3.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
index 54dc9055d536..6c88026312d9 100644
--- a/dev-python/distro/Manifest
+++ b/dev-python/distro/Manifest
@@ -1 +1,2 @@
DIST distro-1.0.4.tar.gz 28772 BLAKE2B 1a337c0a5c125b89adbd3173d17390c5cce12c8549a3e7d90d88fd71f53d1b4c7bc3d1fc87f7bec33d7b4b1311539deaa9414b143daf40108b15dd78370450d8 SHA512 466f2e14b169998e3ff7420e12bf270ad9f934962ae92c2d24bdd747897ad66cb348194dd1376b8b53ed298ea02039943c80d9ccc6b8a01c2bd0c6d2be82c7f6
+DIST distro-1.3.0.tar.gz 48067 BLAKE2B b8dc48dc82e96c674c5fedf2f55167fcbabacde59954ce978085f0a05e5184bf8c323c76208f2ebe0a2cfb6ac41ce0351774ba6ba02dd13b22a7506ce3e5cf58 SHA512 5a3e363b7dbfb5f70967937d04b566e5c8aea10b6f3b9be7485e6f49130766ec5480ce1c1c14ec759e38b2488ffa697478246e53be72ad277cf3bebac7dde741
diff --git a/dev-python/distro/distro-1.3.0.ebuild b/dev-python/distro/distro-1.3.0.ebuild
new file mode 100644
index 000000000000..24530d370bc7
--- /dev/null
+++ b/dev-python/distro/distro-1.3.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="https://distro.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest