summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-23 09:33:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-23 10:12:24 +0300
commitae6453e0f82c61834c543841a603d520fd0771fe (patch)
treefb3a325935d82188c97d6645412eec27792ee1b7 /dev-python/denonavr
parentdev-java/woodstox-core: drop 6.2.7 (diff)
downloadgentoo-ae6453e0f82c61834c543841a603d520fd0771fe.tar.gz
gentoo-ae6453e0f82c61834c543841a603d520fd0771fe.tar.bz2
gentoo-ae6453e0f82c61834c543841a603d520fd0771fe.zip
dev-python/denonavr: add 0.10.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.10.11.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index e146ef5b791a..d72224492991 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1,2 +1,3 @@
DIST denonavr-0.10.10.tar.gz 149803 BLAKE2B a2a034c05cee5b7c6eb51280f4064f41e1228e303043717bb7d4bf08a47230263eb0ab7a96f226ebedaeecd972c1f25f297a1ae3911c44d48949fd113e2e11a9 SHA512 219b04e64055c6d659db09229f895ea3acc90a9d6398d6d53d51753a14779603b8ff983b6c62aa6ce46c0945d11d9e48ff22ca9d9b36a81121cf5dfd4ffac21c
+DIST denonavr-0.10.11.tar.gz 157622 BLAKE2B aa311eff51dbba857f529aee1a1931b3456b7c42f4710d21aff0eb6cf21718d639795d8099e8b0ad297787ba887746b265f922c19afe692cc3317291023a2df3 SHA512 19a10196019067605a2565be4ee0dc56116d6f706ca97c6754e6dc63cccc8870ee657736fd17f1959753c1c24c878e0d7a721c33212e6753dc12b5fc7dae34e0
DIST denonavr-0.10.9.tar.gz 152589 BLAKE2B c517e7d2fbdb23f4b684ffbb206528a641ec9d64e48f1d7aa8a4dd1247ca779bb2bda8a9deab1a985d713d275dc68fa6f961205e33b8bcc7749d9cb3c943f752 SHA512 134b940516a312afb03b2c5fa11a5fb68374c6e5d636332e8a7034ee6c94d2baf70b53e979c1c751eaaab6d31822de4450ceddeab12c42dfc9dd74b934593621
diff --git a/dev-python/denonavr/denonavr-0.10.11.ebuild b/dev-python/denonavr/denonavr-0.10.11.ebuild
new file mode 100644
index 000000000000..586fe3818805
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.10.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="https://github.com/scarface-4711/denonavr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest