summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-08 07:37:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-08 07:38:31 +0100
commitba7a1e774d253734b23365c2804ec7574c40b428 (patch)
tree580400f6e6a0bd1999e88444dc68665609fa78ad /dev-python/ddt
parentdev-python/aiounittest: New package, v1.4.2 (diff)
downloadgentoo-ba7a1e774d253734b23365c2804ec7574c40b428.tar.gz
gentoo-ba7a1e774d253734b23365c2804ec7574c40b428.tar.bz2
gentoo-ba7a1e774d253734b23365c2804ec7574c40b428.zip
dev-python/ddt: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ddt')
-rw-r--r--dev-python/ddt/Manifest1
-rw-r--r--dev-python/ddt/ddt-1.7.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/ddt/Manifest b/dev-python/ddt/Manifest
index a6d9b01d924d..0c63dab078e9 100644
--- a/dev-python/ddt/Manifest
+++ b/dev-python/ddt/Manifest
@@ -1 +1,2 @@
DIST ddt-1.6.0.gh.tar.gz 19615 BLAKE2B f79e25e9da39615d85f000c1029babef64725b159a2b77003efe9f9c5869fb26087fa20e1a58eea485479b12ee89c602076613a9d50711347a775a09c4bbb180 SHA512 c5ea14d3f60384676d9631c84d938b774dd360cea9b0ee1b111692dc2bc06238b5ffd3ab8950207b77aa007bac0ac79b290533a2532be4bee68b642629843a82
+DIST ddt-1.7.0.gh.tar.gz 19742 BLAKE2B aafecea2363f9a1dc102dde1e19ce8f55def7555755342cb23cd027eda7afd0fbf9bb8b5a45a079cce107dfab9b7a78055b81258f206a593955941ce222f1393 SHA512 1f049c1f86cd58867b6ef3d094310e78c94bd11f5602e8a9ffe392bbcf173f23be4f6b77730953b7d747d56a31a3a378d229c7d697383c2e3ce4517d12d13d2d
diff --git a/dev-python/ddt/ddt-1.7.0.ebuild b/dev-python/ddt/ddt-1.7.0.ebuild
new file mode 100644
index 000000000000..37f0d8434bfd
--- /dev/null
+++ b/dev-python/ddt/ddt-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Data-Driven/Decorated Tests"
+HOMEPAGE="
+ https://pypi.org/project/ddt/
+ https://github.com/datadriventests/ddt/
+"
+SRC_URI="
+ https://github.com/datadriventests/ddt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/aiounittest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest