summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-06-01 21:58:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-06-01 21:59:04 -0500
commit456b284e1468775a3c9bddeb0bcc098156896e5d (patch)
tree4ce4de95504f3c62310109101ff6a6c4f7789699 /dev-python/ddt
parentnet-dns/dnsmasq: Don't require idn with nls anymore (diff)
downloadgentoo-456b284e1468775a3c9bddeb0bcc098156896e5d.tar.gz
gentoo-456b284e1468775a3c9bddeb0bcc098156896e5d.tar.bz2
gentoo-456b284e1468775a3c9bddeb0bcc098156896e5d.zip
dev-python/ddt: Version bump to 1.1.1, enable tests
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/ddt')
-rw-r--r--dev-python/ddt/Manifest1
-rw-r--r--dev-python/ddt/ddt-1.1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ddt/Manifest b/dev-python/ddt/Manifest
index 8720a6b08b10..b7aba89fcc8f 100644
--- a/dev-python/ddt/Manifest
+++ b/dev-python/ddt/Manifest
@@ -1 +1,2 @@
DIST ddt-1.1.0.tar.gz 6155 SHA256 1ab0d77e5ecfae9a2b4244dd8079d8e248a69eae0260238516c260ac5e2bd007 SHA512 86e8ffa8fa3a4d2c550898bd64201c3ea26de7692063e3076f5339d5731b9fdeb2d0aea772ff0702c2c359a291836e6486d97e8faa8874e1ebdb7ac9ac3b0385 WHIRLPOOL 7fd9b02ecee7976e39e5112898316fd1f9c1fb768da60397734070b622a0aac4aa1d348352d16ba96ddacb74bf4b9266933784890f253c398ae3495fd934dccb
+DIST ddt-1.1.1.tar.gz 10021 SHA256 d6dc0fc0ec23c369090456ceaaf8baa43df8171a6906c44e52909edce78c00b0 SHA512 3839ac0448292bde07d676456640cd9466353e8c4481e60cb51e33704c21f92fdf840901430aa7f5276ccf579a7cd70b277fa2ceae03bce183e2422d514897a9 WHIRLPOOL 0c10f49c7238edaf115d481e66ba716fed54aac4aa23bdfbe56da8354d8136a236154d4795c723f13aa46fd57654b7423632338d4d810d9bbe33101a3809df0e
diff --git a/dev-python/ddt/ddt-1.1.1.ebuild b/dev-python/ddt/ddt-1.1.1.ebuild
new file mode 100644
index 000000000000..7e5f62ce3f48
--- /dev/null
+++ b/dev-python/ddt/ddt-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to multiply test cases"
+HOMEPAGE="https://pypi.python.org/pypi/ddt https://github.com/txels/ddt"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --with-cov --cover-package=ddt -v || die
+}