summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:48:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:08 -0500
commit17f9572ab1ce28e2f0c2beaccb139e8e7898aed5 (patch)
treedc279699ed32a6059542ed5b5878a66f6df54d9c /dev-python/coverage
parentdev-python/oslotest: 3.7.1 bump (diff)
downloadgentoo-17f9572ab1ce28e2f0c2beaccb139e8e7898aed5.tar.gz
gentoo-17f9572ab1ce28e2f0c2beaccb139e8e7898aed5.tar.bz2
gentoo-17f9572ab1ce28e2f0c2beaccb139e8e7898aed5.zip
dev-python/coverage: 4.5.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-4.5.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index bf6e93cc1af6..228936e76297 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1 +1,2 @@
DIST coverage-4.2.tar.gz 359873 BLAKE2B 4bca9c44922ad99203d65387267c62bee02b0368dfd70c758dbed959ebaa1352366603359865662cde863ca1518de21a4d33d22b86b78ff75c2c23aecf4d726c SHA512 17c508e65e8494bda51dc301eb99e24f39392cc3efe54eee5d94bf45021f91cb5e1acc192981974eb1725e01cd4590c80308bf9bb237a129c2de067bd4556e23
+DIST coverage-4.5.2.tar.gz 384845 BLAKE2B a7b4f249a68e025449d26ef8ee2194b9ce355c979d1f5192a7863a0ab0089f9deb3a8e63a39bef528ed7c58fbcc7cd4bc193fea3a135f5996a6655268a6b7a93 SHA512 0d98c8118648a319ac6f3b4c4c6f1ff8a92085bbe8276dd5504c8df4638933f920d7382d8e6de8e16bff43b62091310e0eab7b7722c6d28c976baedbfae3d03e
diff --git a/dev-python/coverage/coverage-4.5.2.ebuild b/dev-python/coverage/coverage-4.5.2.ebuild
new file mode 100644
index 000000000000..9cc2e846b7d4
--- /dev/null
+++ b/dev-python/coverage/coverage-4.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ >=dev-python/setuptools-18.4[${PYTHON_USEDEP}]
+ test? (
+ dev-python/PyContracts[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ [[ "${PYTHON}" =~ pypy ]] && export COVERAGE_NO_EXTENSION=no
+ ${PYTHON} "${S}"/igor.py test_with_tracer py || die
+ ${PYTHON} "${S}"/igor.py test_with_tracer c || die
+}