summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-16 08:04:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-16 08:08:48 +0300
commit01302e5f947e0e1be347910f65670fe80be56b72 (patch)
tree560e1e497377073b4335391ed2c5a593d8d4f947 /dev-python/coverage
parentnet-analyzer/thrulay: fix LICENSE (diff)
downloadgentoo-01302e5f947e0e1be347910f65670fe80be56b72.tar.gz
gentoo-01302e5f947e0e1be347910f65670fe80be56b72.tar.bz2
gentoo-01302e5f947e0e1be347910f65670fe80be56b72.zip
dev-python/coverage: drop 6.3.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-6.3.1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 71c2fcb7c51d..b1d0f8be9c94 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,2 +1 @@
-DIST coverage-6.3.1.tar.gz 707088 BLAKE2B 4253f2973fec34dd5737878c6977c4b7cd273d7786f5e34877b2061774a5177cf7905472e6c578f3292120dc9123e74387c2fe71723206efcf9a257563918a28 SHA512 aa91f7f45510ce8120081aef6367bc3f39f56480901b57f8e2c3f26c921b5d2c15c44c1ed628eefdd2f1d2360a2c62063004aeb19d287a50c4b33304f8eae5b7
DIST coverage-6.3.2.tar.gz 709294 BLAKE2B 2da96731ee0065fb6139af7db073284a83efa135e7379d2a6d6e571cdf58c888cf72719fbddadb1bd8f62b0b155b8420a84377068c40e4c813533b3ad6b190a8 SHA512 d9ea3a93eefe2dbb723ed1eadb09dc1165c4f46e7186889ce3615411283baac1d80f04a3831208a164f99accea5d246d4613a7c2e909d2e63d3c714620432a16
diff --git a/dev-python/coverage/coverage-6.3.1.ebuild b/dev-python/coverage/coverage-6.3.1.ebuild
deleted file mode 100644
index 7ceab2052d7d..000000000000
--- a/dev-python/coverage/coverage-6.3.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-inherit distutils-r1
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-#IUSE="test"
-# The tests are impossible to appease. Please run them externally
-# via tox. Or fix the ebuild if you have hours of time to spend
-# on something utterly useless.
-RESTRICT="test"
-
-#BDEPEND="
-# test? (
-# dev-python/PyContracts[${PYTHON_USEDEP}]
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/hypothesis[${PYTHON_USEDEP}]
-# dev-python/mock[${PYTHON_USEDEP}]
-# dev-python/pytest[${PYTHON_USEDEP}]
-# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
-# )
-#"
-
-src_prepare() {
- # avoid the dep on xdist
- sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${EPYTHON}" igor.py zip_mods || die
- "${EPYTHON}" igor.py test_with_tracer py || die
-
- # No C extensions under pypy
- if [[ ${EPYTHON} != pypy* ]]; then
- cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
- "${EPYTHON}" igor.py test_with_tracer c || die
- fi
-
- # clean up leftover "egg1" directory
- rm -rf build/lib/egg1 || die
-}