summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-03 18:33:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-03 19:35:07 +0100
commit72653c102f65e39c0cc58890d6ccf18dc8c3a463 (patch)
tree7b6720a34c306cae3ec68e4909cef79dc1699c32 /dev-python/contourpy
parentnet-vpn/tor: Stabilize 0.4.7.16 ppc64, #916761 (diff)
downloadgentoo-72653c102f65e39c0cc58890d6ccf18dc8c3a463.tar.gz
gentoo-72653c102f65e39c0cc58890d6ccf18dc8c3a463.tar.bz2
gentoo-72653c102f65e39c0cc58890d6ccf18dc8c3a463.zip
dev-python/contourpy: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest1
-rw-r--r--dev-python/contourpy/contourpy-1.2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index ed74b5b4c7d1..22a61be7f39f 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1 +1,2 @@
DIST contourpy-1.1.1.gh.tar.gz 13417093 BLAKE2B 217b99a1000575d362ca60327f39d39fd5f241f1e0f94ac3f049e2bf195388424f10bfd33c2a007da32eb939c1a04e96942ce0092c091533166c54da906b68af SHA512 7d135f18fa28ecd5d6c715650fc5672291c6f46e96cfcf8d2571c401d5bae0d27fa6a2e9f80e4f735af3016c7ced92552f26e8c5519e725e1bf6fe54c7603a03
+DIST contourpy-1.2.0.gh.tar.gz 13440145 BLAKE2B c8082f69c3c8ad2b9a2d7a8e68941f1b741b0527161df371b501a32b8f0572a012aa2184b9f3ea943f45143f218f910180e31371683826d2b9b9431537c72cbd SHA512 91084ca659f796fb49f34840fb08a1a8f2a78ce8264668f5729550b1c46f316933c1d76ed87797bf58a059f0cf63e6efc58c92e44c57787fc8ad1ca16a21aa6e
diff --git a/dev-python/contourpy/contourpy-1.2.0.ebuild b/dev-python/contourpy/contourpy-1.2.0.ebuild
new file mode 100644
index 000000000000..dd6add3e91a1
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/wurlitzer[${PYTHON_USEDEP}]
+ )
+"
+
+DISTUTILS_ARGS=(
+ -Dwerror=false
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}