summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-11-28 15:25:04 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-29 09:15:59 +0100
commit7b95f1874c2403ab082ab95877a3f7c94143988f (patch)
tree6f89bc387203ccd8d8560b14133f5868398c3b34 /dev-python/chump/chump-1.5.2.ebuild
parentdev-python/backports-unittest-mock: bump to 1.2.1, add doc (diff)
downloadgentoo-7b95f1874c2403ab082ab95877a3f7c94143988f.tar.gz
gentoo-7b95f1874c2403ab082ab95877a3f7c94143988f.tar.bz2
gentoo-7b95f1874c2403ab082ab95877a3f7c94143988f.zip
dev-python/chump: bump to 1.5.2, add doc
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2946
Diffstat (limited to 'dev-python/chump/chump-1.5.2.ebuild')
-rw-r--r--dev-python/chump/chump-1.5.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/chump/chump-1.5.2.ebuild b/dev-python/chump/chump-1.5.2.ebuild
new file mode 100644
index 000000000000..129cd212bbe1
--- /dev/null
+++ b/dev-python/chump/chump-1.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+# PyPI tarballs currently don't contain docs
+# https://github.com/karanlyons/chump/pull/10
+# Releases are not tagged on GitHub
+# https://github.com/karanlyons/chump/issues/9
+SRC_URI="https://github.com/karanlyons/${PN}/archive/0cd59e14267858ab6623d7aa42badc6caa9b8edf.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Force sphinx to use the standard theme
+ use doc && READTHEDOCS=True emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}