summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-06 05:25:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-06 07:02:12 +0100
commit96828f8dee95c9f0644b7581cbc32fc9f2a7548c (patch)
treebd12616b16a7e876a753d2fc3e58c8e6b308e9e1 /dev-python/cfn-lint
parentapp-admin/awscli: Bump to 1.27.23 (diff)
downloadgentoo-96828f8dee95c9f0644b7581cbc32fc9f2a7548c.tar.gz
gentoo-96828f8dee95c9f0644b7581cbc32fc9f2a7548c.tar.bz2
gentoo-96828f8dee95c9f0644b7581cbc32fc9f2a7548c.zip
dev-python/cfn-lint: Bump to 0.72.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.72.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 7b72293871c4..b78d21fb798a 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -5,3 +5,4 @@ DIST cfn-lint-0.71.0.gh.tar.gz 2970400 BLAKE2B f57f8605a05004dfe6207a313126c74d1
DIST cfn-lint-0.71.1.gh.tar.gz 2984397 BLAKE2B faa2164ee0f469f8e9118b82d5c86dee05e5404feb5ae28abd9e4218122677dba09308d5a573c4eaabb8f321932b8de621a39bc20f1c86724dc24fedac7e7a93 SHA512 dee916eaa43eabcc4cf2db7fb08db8875f68292a56aa97d29d0d291da51a828a78b681162b71759ec0dc3d246570dbce8fe33a41ce61c22e6fbf2a4ff15f49ff
DIST cfn-lint-0.72.0.gh.tar.gz 3027416 BLAKE2B 710c403838d90de46525ce6991aa05bb973fc010b6909d329c8a59159779578f51248f823554faf1c9c9f2fd019235770f1f9ca124426ff1c79d203d7599c5c2 SHA512 c420ab110039c4bc761551ca8665d2c58390ffb0590adf2f8ae3beb3cc2587fae1c96e06faa5baecb6014ce68f580e8f0d285c2ad287718c15d6d6e49ca5d50b
DIST cfn-lint-0.72.1.gh.tar.gz 3061196 BLAKE2B 58bca78db0d2bdc6ce4ee146c47c6f8d1eab272bf9074c7ce73c6caa6fa2dfed2bd05efec7b66c8ac341d9a072012354e4c056c24d1edb16933175db87043f87 SHA512 a58fe5a1c0aae095cdc1dc1e3ed6d5dc080e9a54fb565f68b2a80756e49ab8f1de24043dabe6ff8b9d88732a675074a8c5818a1d0802e91c67275fc19ab23905
+DIST cfn-lint-0.72.2.gh.tar.gz 3114298 BLAKE2B 5a426a046d1a0ffb773f9b34c544ccf9f55467de156f3bc0c3324c9877a1f101da69130c39a0d0144d57557c75e9bbcecc41bb1823fe41c00f14874c516c0033 SHA512 2248e2854410ba889180dd20df1f8c1ec70150b8433a7b4d564c6d9a9c7ceaedc81bf051eeaf1906878e57dc395c5e4c08623574cb9f4dced9ea0a8fbe73325d
diff --git a/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild b/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild
new file mode 100644
index 000000000000..0b3070eb0d84
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.72.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.55.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}