summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-26 10:43:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-26 11:59:24 +0200
commit4310cda05d74694772d091b58d6ae3e9eac04f1b (patch)
tree6681a16d3b63b8a5b5f5618fb30ad74eacffd2a4 /dev-python/boto3
parentdev-python/botocore: Bump to 1.25.0 (diff)
downloadgentoo-4310cda05d74694772d091b58d6ae3e9eac04f1b.tar.gz
gentoo-4310cda05d74694772d091b58d6ae3e9eac04f1b.tar.bz2
gentoo-4310cda05d74694772d091b58d6ae3e9eac04f1b.zip
dev-python/boto3: Bump to 1.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.22.0.ebuild66
-rw-r--r--dev-python/boto3/boto3-9999.ebuild6
3 files changed, 72 insertions, 1 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a2cbc1575e8d..7a649d301eb2 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -12,3 +12,4 @@ DIST boto3-1.21.43.tar.gz 489557 BLAKE2B ad297963b34d176f686f09da408bbd7f236413f
DIST boto3-1.21.44.tar.gz 490125 BLAKE2B 37a18fe2beff3a232f17b809bf19519800b6481f7f2cf727a45ab965d9dee27978ce1efc192fab70925776757c77573eb2703815958dcf8be9388e0fe8081502 SHA512 4ed06c2adf3187d7cbda5ef481883289a83137bd6065c56a61d0b2d452845f55c74ff8bd62f3558463b83abbfccb4c29638d1774c7076539b3e6ec088eefbb6b
DIST boto3-1.21.45.tar.gz 491080 BLAKE2B 32692caeb34f9b8bd515b4cd9fa406b9537912abd24c5f5446ff10adf1a038a423e3c1c17fe6469c51cc35067a128064dcee715de81c46b4b118ddd9fb4a89ff SHA512 538fb81c06e1e14e78d39123c531558f0c2a2206ee0f0c9a282b3a86e179ff76682db206cca5c53d4e3b6deb6ded6f8843ad0d398f8584afca1be042782ba004
DIST boto3-1.21.46.tar.gz 491253 BLAKE2B f55d30087e4f29e3d8ba577d798cd4e4c5fe1f710ac172d6684f005047a422855a6fad91aaaac76e3f33260cbac35be81c8177a80bea913283bcbe7bacb3750f SHA512 0d219b1af786583318a078413a3b30999b2aaad985db72eafe2b63f0068996f0d13b7a48464909cc753d5f9098ea583336ef4887839db5375ebdfcedad3dbffa
+DIST boto3-1.22.0.tar.gz 492175 BLAKE2B cce4b21c0f4de7e70b1c9e402d9e19ccda26e7fc6eab07686c378ae8a9a72a7cf3bb3e2927282e21cd167ca395d63e1fbdfb31d385e5e7a2591c48367c80517c SHA512 b4c51a26e95344ec6e4b876d88148c9603ae7807105ffd0564d928f611c278729f00efd38baff4b31154b358b17ae72c6b90698aef9c013b601bc70d543e2ffb
diff --git a/dev-python/boto3/boto3-1.22.0.ebuild b/dev-python/boto3/boto3-1.22.0.ebuild
new file mode 100644
index 000000000000..23a4a6fecbae
--- /dev/null
+++ b/dev-python/boto3/boto3-1.22.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index 08e404dd41b6..23a4a6fecbae 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -5,10 +5,14 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1 multiprocessing
DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="https://github.com/boto/boto3"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
LICENSE="Apache-2.0"
SLOT="0"