summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 10:14:11 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:09 +0200
commita889e5e599051fe20a6372a9f6d92c09fad461de (patch)
treeee1fe16b2cd41b38b244102fce66a815fb628f33 /dev-python/async_timeout
parentdev-python/async_timeout: Add python@ as co-maint (diff)
downloadgentoo-a889e5e599051fe20a6372a9f6d92c09fad461de.tar.gz
gentoo-a889e5e599051fe20a6372a9f6d92c09fad461de.tar.bz2
gentoo-a889e5e599051fe20a6372a9f6d92c09fad461de.zip
dev-python/async_timeout: Bump to 3.0.1, EAPI=7, Py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_timeout')
-rw-r--r--dev-python/async_timeout/Manifest1
-rw-r--r--dev-python/async_timeout/async_timeout-3.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/async_timeout/Manifest b/dev-python/async_timeout/Manifest
index 4757fed8123a..b7d48a754959 100644
--- a/dev-python/async_timeout/Manifest
+++ b/dev-python/async_timeout/Manifest
@@ -2,4 +2,5 @@ DIST async-timeout-1.1.0.tar.gz 7590 BLAKE2B 855a630b1c1be6751ee416a9f394b93b25d
DIST async-timeout-1.2.0.tar.gz 7700 BLAKE2B a658cc80ba0b35d1f79286d8f6edac4aaf84e1bcef680b1ef096f6f9d14873800f948429d00fe09b26e20ab109c676fb1ca838931a83473f59863d490caf2c0e SHA512 81a8d3fd8a6756335ce7ea292afd0ba508ea120482dfc4526017dbf6ee809e6828818653be25dee123e8626fc89cc49cfbcff41748ec950b8797b2bb21f262db
DIST async-timeout-1.2.1.tar.gz 7797 BLAKE2B d8f736423631a2b2c0fb748eb2857e0f9a143af9591ddfae15d42ab13af33196a6624db5b0a705265269ed28c6c15a4e8cfe56143ccedac75a555ae62a82891b SHA512 2072caeb65a74f1a24b59a4ea905ef96d70f8fb117e3dd9c95c1107b1d67ffaa4d76b68f00364049e6e29cdb0a6d247ba0c3638ccd0a8db27bd6ee0f180f9ccb
DIST async-timeout-3.0.0.tar.gz 10803 BLAKE2B 3cee55e523a652c27f73bb3790d3c214f2744ef1ba3e0fe6fee80e5e4172cab808b08513d1beb99e71a36eda0a27d31fcf23e7a1ea0fb4569dc1310fef3557e6 SHA512 17df44da4d6038dcfa30b1394bcffbe9a31470c45fcd20c21da8dbea154fd2d508afafb19ce4da7f65422057e3a141be2bd9171d0a385556814759da0fb0496f
+DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
DIST async_timeout-1.0.0.tar.gz 7554 BLAKE2B a069f79eb25c1b698f688cff482970c60197ac6f22e610fe487e33180644a197961f97e1afc7d6ba86f9250add9c7c72d386b5209b8d99e0518c137246106225 SHA512 b02fa2f9558d23e6e1cc076f8d144dcfee7adeaad67c023ce747c99935c2809e2a2223f72b0a12274f11bacadc9b69a6bc3a2914c305ef05d483dc29908e9c97
diff --git a/dev-python/async_timeout/async_timeout-3.0.1.ebuild b/dev-python/async_timeout/async_timeout-3.0.1.ebuild
new file mode 100644
index 000000000000..c463132c66a6
--- /dev/null
+++ b/dev-python/async_timeout/async_timeout-3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_P=${PN/_/-}-${PV}
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="https://github.com/aio-libs/async-timeout"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # remove pointless dep on pytest-cov
+ sed -i -e '/addopts/d' setup.cfg || die
+ # tests fail due to missing fixture when trying to load this file
+ rm tests/conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}