summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 16:23:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:14 +0100
commit2d823107fb429059941faddcf624fe6e0184dd59 (patch)
treeadb27f1085a848c6fe4e0e5f45a6410deefe94ed /dev-python/argparse-manpage
parentdev-python/twisted: Bump to 22.10.0 (diff)
downloadgentoo-2d823107fb429059941faddcf624fe6e0184dd59.tar.gz
gentoo-2d823107fb429059941faddcf624fe6e0184dd59.tar.bz2
gentoo-2d823107fb429059941faddcf624fe6e0184dd59.zip
dev-python/argparse-manpage: Bump to v4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argparse-manpage')
-rw-r--r--dev-python/argparse-manpage/Manifest1
-rw-r--r--dev-python/argparse-manpage/argparse-manpage-4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/argparse-manpage/Manifest b/dev-python/argparse-manpage/Manifest
index 818ad4b33ecb..f50d698e74d7 100644
--- a/dev-python/argparse-manpage/Manifest
+++ b/dev-python/argparse-manpage/Manifest
@@ -1 +1,2 @@
DIST argparse-manpage-3.tar.gz 45091 BLAKE2B b2ab9d4863227eacaf566865cd47763b9a52f4fd445ae78cf8212b3762a14c1ceb7f9008d25b8828f5e5da23e120a7be6d48239bb300670e559000de1e75fd68 SHA512 96225cf71dc60c638bd312331622e5b60589d7e6baf59fdfca0d90d24cff2bb232696c754c440c4e239949ea1a6280699c4f0f7816c50ec62bf77474d0c48cf4
+DIST argparse-manpage-4.gh.tar.gz 50506 BLAKE2B b291e4e77a076e87659bea611baf96d9a258deb8d9fe5e8d1a9278d4daa80d108d6bc7280aa351f1f7b5fa725a5a6508dd3d74bfc1dd226d24653645066173f2 SHA512 51b3cd10569b0bbd28587172cbb2818375c904c89c51a075e2f641c4d158a7a047ff939977c3ee0f164ace18ebccc0037f8c0e74e23b41fbcd990cacedcbee6a
diff --git a/dev-python/argparse-manpage/argparse-manpage-4.ebuild b/dev-python/argparse-manpage/argparse-manpage-4.ebuild
new file mode 100644
index 000000000000..9cb83d7cb886
--- /dev/null
+++ b/dev-python/argparse-manpage/argparse-manpage-4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically build man-pages for your Python project"
+HOMEPAGE="
+ https://github.com/praiskup/argparse-manpage/
+ https://pypi.org/project/argparse-manpage/
+"
+SRC_URI="
+ https://github.com/praiskup/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ epytest
+}