summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-03 08:27:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-03 08:27:24 +0200
commitb16730051e07dcfb464cae57e2b71c44a6077e22 (patch)
treec296c61e2b8adbdfa22d67b924c57fd07062c80c /dev-python/argh
parentdev-python/pytest-subtests: Remove old (diff)
downloadgentoo-b16730051e07dcfb464cae57e2b71c44a6077e22.tar.gz
gentoo-b16730051e07dcfb464cae57e2b71c44a6077e22.tar.bz2
gentoo-b16730051e07dcfb464cae57e2b71c44a6077e22.zip
dev-python/argh: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.31.2.ebuild33
-rw-r--r--dev-python/argh/files/argh-0.31.2-py313.patch164
3 files changed, 0 insertions, 198 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index 611118f34f4b..243309230cdc 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,2 +1 @@
-DIST argh-0.31.2.tar.gz 57200 BLAKE2B e5ba440d08d8f5655d237d61ab65fef02296d28d0562945e56dfa6598deafa6cc288d88e625c4acabfa2eeda359f970679db1e7424d77e0278b65fbe15c8b499 SHA512 2e0d926cae88d6830706f631aa2220654777dcc1a4263af889064d4c805616fce368c90e871a393490b9590f82759f56b2434afeba468e7720f99d85c8b75dd1
DIST argh-0.31.3.tar.gz 57570 BLAKE2B cb88813701f42657a8e89cab46be367c751ae59cc05d5eba9cebd77d375a73413b33e76d48bf84b42559fcf25f3d4b87473b124346fd4f3ba5433e60204b06a1 SHA512 c3335f975e612332ee9e3479f4517f356bacaad77f0df1e8660d5306257a8e32b139cdaa49c2c4bfa234f32e39e324182de997313c43ea4f45f2e11de7e2a24c
diff --git a/dev-python/argh/argh-0.31.2.ebuild b/dev-python/argh/argh-0.31.2.ebuild
deleted file mode 100644
index 0c53e95bef20..000000000000
--- a/dev-python/argh/argh-0.31.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A simple argparse wrapper"
-HOMEPAGE="
- https://pythonhosted.org/argh/
- https://github.com/neithere/argh/
- https://pypi.org/project/argh/
-"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/iocapture[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/neithere/argh/commit/cdb70d5ac7d8a5a5dff3c55100e5f67b68b26826
- "${FILESDIR}/${P}-py313.patch"
-)
diff --git a/dev-python/argh/files/argh-0.31.2-py313.patch b/dev-python/argh/files/argh-0.31.2-py313.patch
deleted file mode 100644
index 4049fedc0d0d..000000000000
--- a/dev-python/argh/files/argh-0.31.2-py313.patch
+++ /dev/null
@@ -1,164 +0,0 @@
-From cdb70d5ac7d8a5a5dff3c55100e5f67b68b26826 Mon Sep 17 00:00:00 2001
-From: Andy Mikhaylenko <neithere@gmail.com>
-Date: Sun, 16 Jun 2024 22:38:21 +0200
-Subject: [PATCH] fix: tests under Python 3.13 (fixes #228)
-
-diff --git a/tests/test_integration.py b/tests/test_integration.py
-index f863386..258a148 100644
---- a/tests/test_integration.py
-+++ b/tests/test_integration.py
-@@ -724,18 +724,34 @@ def remind(
- help_normalised = re.sub(r"\s+", " ", parser.format_help())
-
- assert "name 'Basil'" in help_normalised
-- assert "-t TASK, --task TASK 'hang the Moose'" in help_normalised
-- assert (
-- "-r REASON, --reason REASON 'there are creatures living in it'"
-- in help_normalised
-- )
-
-- # explicit help message is not obscured by the implicit one
-- # but is still present
-- assert (
-- "-n NOTE, --note NOTE why is it a remarkable animal? "
-- "(default: 'it can speak English')"
-- ) in help_normalised
-+ # argh#228 — argparse in Python before 3.13 duplicated the placeholder in help
-+ if sys.version_info < (3, 13):
-+ assert "-t TASK, --task TASK 'hang the Moose'" in help_normalised
-+ assert (
-+ "-r REASON, --reason REASON 'there are creatures living in it'"
-+ in help_normalised
-+ )
-+
-+ # explicit help message is not obscured by the implicit one
-+ # but is still present
-+ assert (
-+ "-n NOTE, --note NOTE why is it a remarkable animal? "
-+ "(default: 'it can speak English')"
-+ ) in help_normalised
-+ else:
-+ assert "-t, --task TASK 'hang the Moose'" in help_normalised
-+ assert (
-+ "-r, --reason REASON 'there are creatures living in it'"
-+ in help_normalised
-+ )
-+
-+ # explicit help message is not obscured by the implicit one
-+ # but is still present
-+ assert (
-+ "-n, --note NOTE why is it a remarkable animal? "
-+ "(default: 'it can speak English')"
-+ ) in help_normalised
-
-
- def test_default_arg_values_in_help__regression():
-@@ -750,9 +766,16 @@ def foo(*, bar=""):
- # doesn't break
- parser.format_help()
-
-+ # argh#228 — argparse in Python before 3.13 duplicated the placeholder in help
-+ if sys.version_info < (3, 13):
-+ expected_line = "-b BAR, --bar BAR ''"
-+ # note the empty str repr ^^^
-+ else:
-+ expected_line = "-b, --bar BAR ''"
-+ # note the empty str repr ^^^
-+
- # now check details
-- assert "-b BAR, --bar BAR ''" in parser.format_help()
-- # note the empty str repr ^^^
-+ assert expected_line in parser.format_help()
-
-
- def test_help_formatting_is_preserved():
-@@ -868,6 +891,19 @@ def second_func():
-
- run(parser, "first-func --help", exit=True)
- captured = capsys.readouterr()
-+
-+ # argh#228 — argparse in Python before 3.13 duplicated the placeholder in help
-+ if sys.version_info < (3, 13):
-+ arg_help_lines = (
-+ " -h, --help show this help message and exit\n"
-+ " -f FOO, --foo FOO 123"
-+ )
-+ else:
-+ arg_help_lines = (
-+ " -h, --help show this help message and exit\n"
-+ " -f, --foo FOO 123"
-+ )
-+
- assert (
- captured.out
- == unindent(
-@@ -877,8 +913,7 @@ def second_func():
- Owl stretching time
-
- {HELP_OPTIONS_LABEL}:
-- -h, --help show this help message and exit
-- -f FOO, --foo FOO 123
-+ {arg_help_lines}
- """
- )[1:]
- )
-@@ -997,6 +1032,19 @@ def second_func():
-
- run(parser, "my-group first-func --help", exit=True)
- captured = capsys.readouterr()
-+
-+ # argh#228 — argparse in Python before 3.13 duplicated the placeholder in help
-+ if sys.version_info < (3, 13):
-+ arg_help_lines = (
-+ " -h, --help show this help message and exit\n"
-+ " -f FOO, --foo FOO 123"
-+ )
-+ else:
-+ arg_help_lines = (
-+ " -h, --help show this help message and exit\n"
-+ " -f, --foo FOO 123"
-+ )
-+
- assert (
- captured.out
- == unindent(
-@@ -1006,8 +1054,7 @@ def second_func():
- Owl stretching time
-
- {HELP_OPTIONS_LABEL}:
-- -h, --help show this help message and exit
-- -f FOO, --foo FOO 123
-+ {arg_help_lines}
- """
- )[1:]
- )
-@@ -1079,6 +1126,19 @@ def second_func():
-
- run(parser, "first-func --help", exit=True)
- captured = capsys.readouterr()
-+
-+ # argh#228 — argparse in Python before 3.13 duplicated the placeholder in help
-+ if sys.version_info < (3, 13):
-+ arg_help_lines = (
-+ " -h, --help show this help message and exit\n"
-+ " -f FOO, --foo FOO 123"
-+ )
-+ else:
-+ arg_help_lines = (
-+ " -h, --help show this help message and exit\n"
-+ " -f, --foo FOO 123"
-+ )
-+
- assert (
- captured.out
- == unindent(
-@@ -1088,8 +1148,7 @@ def second_func():
- func description override
-
- {HELP_OPTIONS_LABEL}:
-- -h, --help show this help message and exit
-- -f FOO, --foo FOO 123
-+ {arg_help_lines}
- """
- )[1:]
- )