summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-08 08:45:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-08 10:51:59 +0200
commit20df31578bf934fb79bfe5199e90a73a9ca994b8 (patch)
tree34f033c2ce63ff42a499d7be80a117cd7740feff /dev-python/apispec
parentdev-python/irc: Enable python3.10 (diff)
downloadgentoo-20df31578bf934fb79bfe5199e90a73a9ca994b8.tar.gz
gentoo-20df31578bf934fb79bfe5199e90a73a9ca994b8.tar.bz2
gentoo-20df31578bf934fb79bfe5199e90a73a9ca994b8.zip
dev-python/apispec: Bump to 4.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-4.4.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index f512ca1a9bc0..e817ad0920bf 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -2,3 +2,4 @@ DIST apispec-3.3.0.tar.gz 61687 BLAKE2B f1bcd212494d9196441e44acd4fd0d06063d7f80
DIST apispec-4.2.0.tar.gz 63046 BLAKE2B 4a6729975e28d22a23b0574f8298f3113ed89cdcc7d01e3086af82354d4a61b4a82420ab7ca7b66790481dd8e3232ebe80319266fb2de54c0aa8c6c3a7fa86a1 SHA512 51187a80f8ad260bd0a89d4a882d2517f56237a6cfb0596cf29999e3fc42af0700c88037ba205a4e7f51587abf8b1db5dbae7ee5d98ae55fc9fe2314f69fa656
DIST apispec-4.3.0.tar.gz 63351 BLAKE2B 3d5836df242cc0562ce9e8ef47dc352cdb415b8e33b86e835140d88b4b87b7aff3db6d975f3fe7d7541be0e19bfcc451dd9a909ab4b830a35191b5b624930132 SHA512 c42b47697948b4d111bed83b71e2d7e6e7b9972bc44cd642a579444019c468acf6a0c9411273d234b8b2b63d2cfcaaccd1f9d125cffb0d44701a6025ada4a0f3
DIST apispec-4.4.0.tar.gz 64266 BLAKE2B c87ed439f6b7ca57f89ce86f384362dc4ad4a32663b89ea3b5f5b6600015147c5c5a78aed3555b79715f3283165aea37318f2910dbdb675cf58680df45281531 SHA512 677d7d823a3ea4bc65484a1524a2d8fdea0f4690e69d56ae7138bca0461ae1ddd3cf34c20bb0d4f1a6270cf9895c053a4a0c0db8e5fd975da8fcd61b123532dd
+DIST apispec-4.4.1.tar.gz 64424 BLAKE2B b46390659334f5ce5aa83fd15207f5d1ad6d0e9c530f9e7d2b1a0f6a787498aad065153cde9237ce1ab408256e5cd698bbc674dc0316eb4ed16b874ce34611c4 SHA512 fea0787598ca93711eaa231675f97623eb3d6eb224e11c40e66857b95f48724618bf7a9bfda476b56c1c96fe70bb61675966b1f3fb073fe3f7e4da91e78d3d90
diff --git a/dev-python/apispec/apispec-4.4.1.ebuild b/dev-python/apispec/apispec-4.4.1.ebuild
new file mode 100644
index 000000000000..9e530e3935f3
--- /dev/null
+++ b/dev-python/apispec/apispec-4.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="https://github.com/marshmallow-code/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}