summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 07:23:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 08:02:34 +0200
commitcd41cccf08e3428e354ac4ef99c7027ea99ac8e1 (patch)
tree8999571c3b6273b1220749d486ded7edf2f34982 /dev-python/aiosmtpd
parentdev-python/pygit2: Bump to 1.15.0 (diff)
downloadgentoo-cd41cccf08e3428e354ac4ef99c7027ea99ac8e1.tar.gz
gentoo-cd41cccf08e3428e354ac4ef99c7027ea99ac8e1.tar.bz2
gentoo-cd41cccf08e3428e354ac4ef99c7027ea99ac8e1.zip
dev-python/aiosmtpd: Bump to 1.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.4.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index e5676bd746f4..bdc661d6a878 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -1 +1,2 @@
DIST aiosmtpd-1.4.5.tar.gz 152668 BLAKE2B 5f689e029afcc267b8b9f1863ce20d76bea16985d7fddac1e6cf0624d7bef6bbbe7089b4933bee8b5aaa74e63d996295e3684b3a7891b697608cbd311be92728 SHA512 c9507e25b5aeec442d299e13624ce00777ecf8089eee230b9cb9f92c18816cef890968c25144a56b95fd9b063b1440921841a16add624d717b8f6378d55c85a4
+DIST aiosmtpd-1.4.6.tar.gz 152775 BLAKE2B 6432388c563bc9e8439f0e685130e103a855004443d24e004ab7bf740c0e93cb7601fc435104f7c1c450e1d6374fe9070ed4a91df58ca0f013e516cd9f40e748 SHA512 5aceaa03d6a00c3c99cd2d53b9320aa3a044d0ee09c22bd4fadf3ee56ea0e307120d1fe4cc798d7a04d53059da674f6dba816a6a6ed7326a510f6caf074e8f90
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.4.6.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.4.6.ebuild
new file mode 100644
index 000000000000..9ba4752f000d
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reimplementation of the Python stdlib smtpd.py based on asyncio"
+HOMEPAGE="
+ https://aiosmtpd.aio-libs.org/
+ https://github.com/aio-libs/aiosmtpd
+ https://pypi.org/project/aiosmtpd/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/atpublic-4.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( >=dev-python/pytest-mock-3.12.0[${PYTHON_USEDEP}] )
+"
+
+EPYTEST_DESELECT=(
+ # Needs dev-vcs/git
+ aiosmtpd/qa/test_0packaging.py::TestVersion
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov=/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}