summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 18:01:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 18:01:57 +0100
commitca95b314c2550315ef210974642a862dd12870aa (patch)
tree242382b2c56b8bcb39520b55ad2e3834815d9d74 /dev-python/aiorpcX
parentdev-python/python-ptrace: update upstream metadata (diff)
downloadgentoo-ca95b314c2550315ef210974642a862dd12870aa.tar.gz
gentoo-ca95b314c2550315ef210974642a862dd12870aa.tar.bz2
gentoo-ca95b314c2550315ef210974642a862dd12870aa.zip
dev-python/aiorpcX: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild b/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
new file mode 100644
index 000000000000..478599928eee
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="
+ https://github.com/kyuupichan/aiorpcX/
+ https://pypi.org/project/aiorpcX/
+"
+SRC_URI="
+ https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+)