summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-10-01 14:15:05 -0400
committerBrian Evans <grknight@gentoo.org>2019-10-01 15:05:07 -0400
commit5d54c1127dca5e68dbf71d512217e3b66825ae62 (patch)
tree72c84c1287fd15267c950e18cc189437895e0e53 /dev-php
parentdev-php/igbinary: Revbump to add php7-4 (diff)
downloadgentoo-5d54c1127dca5e68dbf71d512217e3b66825ae62.tar.gz
gentoo-5d54c1127dca5e68dbf71d512217e3b66825ae62.tar.bz2
gentoo-5d54c1127dca5e68dbf71d512217e3b66825ae62.zip
dev-php/pecl-apcu: Fix USE naming to not include an underscore
Closes: https://bugs.gentoo.org/695080 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu/metadata.xml8
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-4.0.11.ebuild8
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild10
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild8
4 files changed, 17 insertions, 17 deletions
diff --git a/dev-php/pecl-apcu/metadata.xml b/dev-php/pecl-apcu/metadata.xml
index 4d7374447c6f..6344b62d774f 100644
--- a/dev-php/pecl-apcu/metadata.xml
+++ b/dev-php/pecl-apcu/metadata.xml
@@ -6,9 +6,9 @@
<name>PHP</name>
</maintainer>
<use>
- <flag name="lock_semaphore">Enable semaphore locks instead of fcntl</flag>
- <flag name="lock_pthreadmutex">Enable pthread mutex locking</flag>
- <flag name="lock_pthreadrw">Enable pthread read/write locking</flag>
- <flag name="lock_spinlock">Enable spin locks (EXPERIMENTAL)</flag>
+ <flag name="lock-semaphore">Enable semaphore locks instead of fcntl</flag>
+ <flag name="lock-pthreadmutex">Enable pthread mutex locking</flag>
+ <flag name="lock-pthreadrw">Enable pthread read/write locking</flag>
+ <flag name="lock-spinlock">Enable spin locks (EXPERIMENTAL)</flag>
</use>
</pkgmetadata>
diff --git a/dev-php/pecl-apcu/pecl-apcu-4.0.11.ebuild b/dev-php/pecl-apcu/pecl-apcu-4.0.11.ebuild
index f755261e9186..c808e24e7871 100644
--- a/dev-php/pecl-apcu/pecl-apcu-4.0.11.ebuild
+++ b/dev-php/pecl-apcu/pecl-apcu-4.0.11.ebuild
@@ -32,10 +32,10 @@ LOCKS="pthreadmutex pthreadrw spinlock semaphore"
LUSE=""
for l in ${LOCKS}; do
- LUSE+="lock_${l} "
+ LUSE+="lock-${l} "
done
-IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+IUSE+=" ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
REQUIRED_USE="^^ ( $LUSE )"
@@ -52,8 +52,8 @@ src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-apcu
$(use_enable mmap apcu-mmap)
- $(use_enable lock_pthreadrw apcu-rwlocks)
- $(use_enable lock_spinlock apcu-spinlocks)
+ $(use_enable lock-pthreadrw apcu-rwlocks)
+ $(use_enable lock-spinlock apcu-spinlocks)
)
php-ext-source-r3_src_configure
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
index 675490a1e856..da6a7f85c523 100644
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,10 +31,10 @@ LOCKS="pthreadmutex pthreadrw spinlock semaphore"
LUSE=""
for l in ${LOCKS}; do
- LUSE+="lock_${l} "
+ LUSE+="lock-${l} "
done
-IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+IUSE+=" ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
REQUIRED_USE="^^ ( $LUSE )"
@@ -51,8 +51,8 @@ src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-apcu
$(use_enable mmap apcu-mmap)
- $(use_enable lock_pthreadrw apcu-rwlocks)
- $(use_enable lock_spinlock apcu-spinlocks)
+ $(use_enable lock-pthreadrw apcu-rwlocks)
+ $(use_enable lock-spinlock apcu-spinlocks)
)
php-ext-source-r3_src_configure
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild
index 39a64219bf7e..f204ffcad33e 100644
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.17.ebuild
@@ -31,10 +31,10 @@ LOCKS="pthreadmutex pthreadrw spinlock semaphore"
LUSE=""
for l in ${LOCKS}; do
- LUSE+="lock_${l} "
+ LUSE+="lock-${l} "
done
-IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+IUSE+=" ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
REQUIRED_USE="^^ ( $LUSE )"
@@ -51,8 +51,8 @@ src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-apcu
$(use_enable mmap apcu-mmap)
- $(use_enable lock_pthreadrw apcu-rwlocks)
- $(use_enable lock_spinlock apcu-spinlocks)
+ $(use_enable lock-pthreadrw apcu-rwlocks)
+ $(use_enable lock-spinlock apcu-spinlocks)
)
php-ext-source-r3_src_configure