summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-12-09 16:21:49 -0500
committerBrian Evans <grknight@gentoo.org>2022-12-09 16:23:26 -0500
commit490ac72a3ba093a315337bf989721610239e99fd (patch)
treeadac3c258e7af925af697fb38adc03928a17797f /dev-php
parentnet-dns/pdns: add 4.7.3 (diff)
downloadgentoo-490ac72a3ba093a315337bf989721610239e99fd.tar.gz
gentoo-490ac72a3ba093a315337bf989721610239e99fd.tar.bz2
gentoo-490ac72a3ba093a315337bf989721610239e99fd.zip
dev-php/pecl-stomp: Version bump for 2.0.3
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-stomp/Manifest1
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/Manifest b/dev-php/pecl-stomp/Manifest
index 5b21b5de59df..a9923eb89b0a 100644
--- a/dev-php/pecl-stomp/Manifest
+++ b/dev-php/pecl-stomp/Manifest
@@ -1 +1,2 @@
DIST stomp-2.0.2.tgz 23609 BLAKE2B b6ed89b5b8fd0bb501b2337e87107797eedc6ac53c81ba86d2e755cfa2dd716bf4e409cee623430791e0b4854833ef44ed7f6f9e1d89fcd2250d598af0dcaea6 SHA512 577a781b45ef394cd833fb69c808da9b8a8ff69b31b1093c5eef3f7b5d1b37cd0b45c32a03883f56f86213e32bb18aaf0a80010c6bec7efa7239ea48bc57b4b4
+DIST stomp-2.0.3.tgz 23518 BLAKE2B f0253d0e6d1bb51d95007ce2580cb4e5a271547b73705d1ab5be36975cd58068e5fceea64b1451e438fb17601c1b1f513f287b189e3d2922747f735a48e582ef SHA512 e34a63d776cb79da7676d200e4aa2b4a9d4272014fff30eb4c07bc27417d8dc4e7738fb8d62e283cdaac0a411a7bd6e06ef5b06171caa629a404601d14da71d6
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.3.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.3.ebuild
new file mode 100644
index 000000000000..fc45df0a10a7
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
+PHP_EXT_NAME="stomp"
+PHP_EXT_NEEDED_USE="ssl(-)?"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl yes no)
+ )
+ php-ext-source-r3_src_configure
+}