summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 16:19:33 +0000
committerSam James <sam@gentoo.org>2022-07-02 16:19:37 +0000
commit3b6e787f1cd399ffbbae57fcb6adb360bca31fa9 (patch)
tree92ee057258a193bd383aa5f2668aca561a18a94a /dev-perl
parentdev-libs/ossp-uuid: [QA] cleanups (diff)
downloadgentoo-3b6e787f1cd399ffbbae57fcb6adb360bca31fa9.tar.gz
gentoo-3b6e787f1cd399ffbbae57fcb6adb360bca31fa9.tar.bz2
gentoo-3b6e787f1cd399ffbbae57fcb6adb360bca31fa9.zip
dev-perl/Apache-Test: add 1.430.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild105
-rw-r--r--dev-perl/Apache-Test/Manifest1
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild
new file mode 100644
index 000000000000..30bdf451170c
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.430.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHAY
+# Parallel tests seem to be bad.
+DIST_TEST="do"
+DIST_VERSION=1.43
+inherit depend.apache optfeature perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+need_apache
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.400.0-catfile-import.patch"
+ "${FILESDIR}/${PN}-1.400.0-phpclient.patch"
+)
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_test() {
+ local MODULES=(
+ "Apache::Test ${DIST_VERSION}"
+ "Apache::Test5005compat 0.01"
+ "Apache::TestBuild"
+ "Apache::TestClient"
+ "Apache::TestCommon"
+ "Apache::TestCommonPost"
+ "Apache::TestConfig"
+ "Apache::TestConfigC"
+ "Apache::TestConfigPHP"
+ "Apache::TestConfigParrot"
+ "Apache::TestConfigParse"
+ "Apache::TestConfigPerl"
+ "Apache::TestHarness"
+ "Apache::TestHarnessPHP"
+ "Apache::TestMB"
+ "Apache::TestMM"
+ "Apache::TestPerlDB"
+ "Apache::TestReport"
+ "Apache::TestRequest"
+ "Apache::TestRun"
+ "Apache::TestRunPHP 1.00"
+ "Apache::TestRunParrot 1.00"
+ "Apache::TestRunPerl 1.00"
+ "Apache::TestSSLCA"
+ "Apache::TestServer"
+ "Apache::TestSmoke"
+ "Apache::TestSort"
+ "Apache::TestTrace 0.01"
+ "Apache::TestUtil 0.02"
+ "Bundle::ApacheTest ${DISTVERSION}"
+ )
+
+ has_version "www-apache/mod_perl" && MODULES+=(
+ "Apache::TestHandler"
+ "Apache::TestReportPerl"
+ "Apache::TestSmokePerl"
+ )
+
+ local failed=()
+
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+
+ if [[ ${failed[@]} ]]; then
+ eerror "One or more modules failed compile:"
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors"
+ fi
+
+ perl_rm_files t/more/02testmore.t t/more/04testmore.t
+ perl-module_src_test
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [[ -f "${S}"/.mypacklist ]]; then
+ rm -f "${S}"/.mypacklist
+ fi
+
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ optfeature "Running Perl code natively in Apache via Apache::TestHandler, Apache::TestReportPerl, or Apache::TestSmokePerl" www-apache/mod_perl
+}
diff --git a/dev-perl/Apache-Test/Manifest b/dev-perl/Apache-Test/Manifest
index cdd947b9d5e8..4ff3e27fbdf0 100644
--- a/dev-perl/Apache-Test/Manifest
+++ b/dev-perl/Apache-Test/Manifest
@@ -1 +1,2 @@
DIST Apache-Test-1.42.tar.gz 153621 BLAKE2B 570c61e4b5f17c97376ba9f4ab3cde0b14df367f06b665e31dba9c6675972ad4d1bebe46b08416b0f4749d723a6b909430c9bdd1e5d3b1c6b21d209635f1236a SHA512 ecd78dde1b0db562d591990bcd50fe880d724dce9bfb20dceea3a51b81abd89d40889857e5e7714b586a093ad6f101dfd79c6aa33d63c906c41c532305b6584c
+DIST Apache-Test-1.43.tar.gz 153745 BLAKE2B 10988b293d2e4a890451971c98c3c59b262683c65974475e97b5db76bf019f276a264a53cd68fd1bc94fd21e3e6da3d0ad55f01d2b9bf3f9791db572987943dc SHA512 910001c1ca01536ec6f364d9fedf2a9a3a38ebbbbab4ec7d43829e1066317168727a50712c5474ae4bcbde53a1eec6f20f052d74c39a63c4f3f5b3202c48c64a