summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-12 05:52:32 +0000
committerSam James <sam@gentoo.org>2024-03-12 05:52:32 +0000
commitd9a4c4a5bce7bb45f75c5552adf4e799b6bcb829 (patch)
tree91f52afe460e06e38f5775534be8d4c8fa0f18ef /dev-perl/Unicode-UTF8
parentdev-perl/Unicode-Map8: fix modern C issues (diff)
downloadgentoo-d9a4c4a5bce7bb45f75c5552adf4e799b6bcb829.tar.gz
gentoo-d9a4c4a5bce7bb45f75c5552adf4e799b6bcb829.tar.bz2
gentoo-d9a4c4a5bce7bb45f75c5552adf4e799b6bcb829.zip
dev-perl/Unicode-UTF8: fix 32-bit tests
Closes: https://bugs.gentoo.org/925365 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Unicode-UTF8')
-rw-r--r--dev-perl/Unicode-UTF8/Unicode-UTF8-0.620.0-r1.ebuild6
-rw-r--r--dev-perl/Unicode-UTF8/files/Unicode-UTF8-0.620.0-32-bit.patch52
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-perl/Unicode-UTF8/Unicode-UTF8-0.620.0-r1.ebuild b/dev-perl/Unicode-UTF8/Unicode-UTF8-0.620.0-r1.ebuild
index efe2e84c7e4d..9bf3e2d925c5 100644
--- a/dev-perl/Unicode-UTF8/Unicode-UTF8-0.620.0-r1.ebuild
+++ b/dev-perl/Unicode-UTF8/Unicode-UTF8-0.620.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,10 @@ BDEPEND="${RDEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.620.0-32-bit.patch
+)
+
src_test() {
perl_rm_files t/999_pod.t
perl-module_src_test
diff --git a/dev-perl/Unicode-UTF8/files/Unicode-UTF8-0.620.0-32-bit.patch b/dev-perl/Unicode-UTF8/files/Unicode-UTF8-0.620.0-32-bit.patch
new file mode 100644
index 000000000000..9c243c9d106a
--- /dev/null
+++ b/dev-perl/Unicode-UTF8/files/Unicode-UTF8-0.620.0-32-bit.patch
@@ -0,0 +1,52 @@
+https://bugs.gentoo.org/925365
+https://rt.cpan.org/Public/Bug/Display.html?id=127007
+https://github.com/chansen/p5-unicode-utf8/pull/3
+
+From cb30ee19c31a27254c709b78451159d89c377beb Mon Sep 17 00:00:00 2001
+From: "E. Choroba" <choroba@matfyz.cz>
+Date: Thu, 6 Dec 2018 14:42:09 +0100
+Subject: [PATCH 1/2] Fix 080_super.t for 32-bit
+
+Copied from https://rt.cpan.org/Public/Bug/Display.html?id=127007.
+--- a/t/080_super.t
++++ b/t/080_super.t
+@@ -1,5 +1,6 @@
+ #!perl
+
++use Config;
+ use strict;
+ use warnings;
+ use lib 't';
+@@ -16,8 +17,12 @@ my @SUPER = ();
+ for (my $i = 0x0011_0000; $i < 0x7FFF_FFFF; $i += 0x200000) {
+ push @SUPER, $i;
+ }
+- for (my $i = 0x8000_0000; $i < 0xFFFF_FFFF; $i += 0x400000) {
+- push @SUPER, $i;
++
++ # Doesn't work on 32 bit.
++ if ($Config{ptrsize} == 8) {
++ for (my $i = 0x8000_0000; $i < 0xFFFF_FFFF; $i += 0x400000) {
++ push @SUPER, $i;
++ }
+ }
+ }
+
+
+From f989eaedfe83639c7be35fd429af36452ebaf1d2 Mon Sep 17 00:00:00 2001
+From: "E. Choroba" <choroba@matfyz.cz>
+Date: Tue, 11 Dec 2018 17:30:13 +0100
+Subject: [PATCH 2/2] fixup! Fix 080_super.t for 32-bit
+
+--- a/t/080_super.t
++++ b/t/080_super.t
+@@ -19,7 +19,7 @@ my @SUPER = ();
+ }
+
+ # Doesn't work on 32 bit.
+- if ($Config{ptrsize} == 8) {
++ if ($Config{ivsize} > 4) {
+ for (my $i = 0x8000_0000; $i < 0xFFFF_FFFF; $i += 0x400000) {
+ push @SUPER, $i;
+ }
+