summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-02 06:19:23 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-02 07:26:01 +1300
commit9fcb671517902962dcfc1e0d47663f6e8d473d53 (patch)
treee0d0923746fa7ae3bf714eb78a9d17b073736943 /dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild
parentdev-perl/Math-Prime-XS: Bump to version 0.270.0 (diff)
downloadgentoo-9fcb671517902962dcfc1e0d47663f6e8d473d53.tar.gz
gentoo-9fcb671517902962dcfc1e0d47663f6e8d473d53.tar.bz2
gentoo-9fcb671517902962dcfc1e0d47663f6e8d473d53.zip
dev-perl/Math-Random-Secure: Bump to version 0.80.1
- EAPI6 - Parallel tests Upstream: - Regenerate seed after forking - move from Any::Moose to Moo - Fix warnings in newer perls Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild')
-rw-r--r--dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild b/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild
new file mode 100644
index 000000000000..35fbb53db361
--- /dev/null
+++ b/dev-perl/Math-Random-Secure/Math-Random-Secure-0.80.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=FREW
+DIST_VERSION=0.080001
+inherit perl-module
+
+DESCRIPTION="Cryptographically-secure, cross-platform replacement for rand()"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Moo-2.0.0
+ >=dev-perl/Crypt-Random-Source-0.70
+ >=dev-perl/Math-Random-ISAAC-1.1.0
+ dev-perl/Math-Random-ISAAC-XS"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/List-MoreUtils
+ virtual/perl-Test-Simple
+ dev-perl/Test-SharedFork
+ dev-perl/Test-Warn
+ )
+"
+src_test() {
+ perl_rm_files t/author-*.t t/release-*.t
+ perl-module_src_test
+}