summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-24 22:30:37 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-24 22:31:02 +1200
commitacb9acbf0f5395f9ac77cd4a95fd653c4fb0c6ff (patch)
tree46a24a25a3db3fcb234aab9e319b0c010105106f /dev-perl/Date-Manip/Date-Manip-6.820.0.ebuild
parentapp-arch/zip: EAPI 7 (diff)
downloadgentoo-acb9acbf0f5395f9ac77cd4a95fd653c4fb0c6ff.tar.gz
gentoo-acb9acbf0f5395f9ac77cd4a95fd653c4fb0c6ff.tar.bz2
gentoo-acb9acbf0f5395f9ac77cd4a95fd653c4fb0c6ff.zip
dev-perl/Date-Manip: Bump to version 6.820.0
- EAPI7 - Unconditionally patch bad tests Upstream: - Improved delta handling - Deprecate some parts of Date::Manip::Delta - Speed improvements - Use GMT timezone instead of panicking when timezone not determined - Update to tzdata 2020a - Fix rare problem with recurrences not producing a valid date and infinitely looping - Fix math int overflow on non 64-bit architectures - Fix badly normalized business deltas - Fix incorrectly using 'now' instead of 'stored date' for list_holidays Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Date-Manip/Date-Manip-6.820.0.ebuild')
-rw-r--r--dev-perl/Date-Manip/Date-Manip-6.820.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Date-Manip/Date-Manip-6.820.0.ebuild b/dev-perl/Date-Manip/Date-Manip-6.820.0.ebuild
new file mode 100644
index 000000000000..b30ff8a2c85c
--- /dev/null
+++ b/dev-perl/Date-Manip/Date-Manip-6.820.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SBECK
+DIST_VERSION=6.82
+
+inherit perl-module
+
+DESCRIPTION="Perl date manipulation routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Storable
+ elibc_musl? ( sys-libs/timezone-data )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.670.100
+ test? (
+ >=dev-perl/Test-Inter-1.90.0
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/_pod.t
+ t/_pod_coverage.t
+ t/_version.t
+)
+
+src_test() {
+ TZ=UTC perl-module_src_test
+}