summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 06:12:11 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 06:12:11 +1200
commitce498c57a50fc4e6bd077423b5adc3caebaecd2f (patch)
treed6b463ed39b5c239fa1d0f863104c92e45ccd1e8 /dev-perl/Crypt-DH
parentdev-perl/Crypt-DES_EDE3: -r bump for EAPI7 (diff)
downloadgentoo-ce498c57a50fc4e6bd077423b5adc3caebaecd2f.tar.gz
gentoo-ce498c57a50fc4e6bd077423b5adc3caebaecd2f.tar.bz2
gentoo-ce498c57a50fc4e6bd077423b5adc3caebaecd2f.zip
dev-perl/Crypt-DH: -r bump for EAPI7 + Fixes
- EAPI7 - Ensure a slot for dev-libs/gmp - Migrate sed hacks to a 'patch' Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-DH')
-rw-r--r--dev-perl/Crypt-DH/Crypt-DH-0.70.0-r3.ebuild27
-rw-r--r--dev-perl/Crypt-DH/files/Crypt-DH-0.07-no-dot-inc.patch22
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DH/Crypt-DH-0.70.0-r3.ebuild b/dev-perl/Crypt-DH/Crypt-DH-0.70.0-r3.ebuild
new file mode 100644
index 000000000000..5b5e2e9cc927
--- /dev/null
+++ b/dev-perl/Crypt-DH/Crypt-DH-0.70.0-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MITHALDU
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Diffie-Hellman key exchange system"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND="
+ dev-libs/gmp:0
+ >=dev-perl/Math-BigInt-GMP-1.240.0
+ >=virtual/perl-Math-BigInt-1.600.0
+ dev-perl/Crypt-Random
+"
+DEPEND="dev-libs/gmp:0"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.07-no-dot-inc.patch"
+)
diff --git a/dev-perl/Crypt-DH/files/Crypt-DH-0.07-no-dot-inc.patch b/dev-perl/Crypt-DH/files/Crypt-DH-0.07-no-dot-inc.patch
new file mode 100644
index 000000000000..47a3515ce4c0
--- /dev/null
+++ b/dev-perl/Crypt-DH/files/Crypt-DH-0.07-no-dot-inc.patch
@@ -0,0 +1,22 @@
+From a97d967158b7678e16f9be4ac2eea858572bea0c Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 1 Jul 2020 06:01:52 +1200
+Subject: include "." in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 13f2698..fcd77ae 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,4 +1,5 @@
+ use strict;
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Crypt-DH';
+--
+2.27.0
+