summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 11:42:32 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 11:57:35 +1200
commit7d5bcb8cb51b4819008ddbc0fdd291450a084f1c (patch)
tree50699f78abf6d71c929bf568d1a061522cee35dd /dev-perl/Audio-Scan
parentdev-perl/Audio-Mixer: -r bump for CFLAGS love (diff)
downloadgentoo-7d5bcb8cb51b4819008ddbc0fdd291450a084f1c.tar.gz
gentoo-7d5bcb8cb51b4819008ddbc0fdd291450a084f1c.tar.bz2
gentoo-7d5bcb8cb51b4819008ddbc0fdd291450a084f1c.zip
dev-perl/Audio-Scan: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Remove empty/unused variable assignments - Ensure CFLAGS passed to make/compile Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Audio-Scan')
-rw-r--r--dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild b/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..a0ef36b985a1
--- /dev/null
+++ b/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AGRUNDMA
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Fast C metadata and tag reader for all common audio file formats"
+# License note: ambiguity: https://rt.cpan.org/Ticket/Display.html?id=132450
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Warn
+ )
+"
+PERL_RM_FILES=(
+ "t/02pod.t"
+ "t/03podcoverage.t"
+ "t/04critic.t"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}