summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-25 20:58:24 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-25 20:58:40 +0200
commit06fb4a8af2e5208bb583183e4b0f30fd4d142a47 (patch)
tree906f13998de4e2190a7c35a7e856834275522c9a /dev-ml/gapi-ocaml
parentsys-apps/openrc: sync live (diff)
downloadgentoo-06fb4a8af2e5208bb583183e4b0f30fd4d142a47.tar.gz
gentoo-06fb4a8af2e5208bb583183e4b0f30fd4d142a47.tar.bz2
gentoo-06fb4a8af2e5208bb583183e4b0f30fd4d142a47.zip
dev-ml/gapi-ocaml: add 0.4.5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/gapi-ocaml')
-rw-r--r--dev-ml/gapi-ocaml/Manifest1
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/Manifest b/dev-ml/gapi-ocaml/Manifest
index be5af9acfbdc..f574ec430166 100644
--- a/dev-ml/gapi-ocaml/Manifest
+++ b/dev-ml/gapi-ocaml/Manifest
@@ -1 +1,2 @@
DIST gapi-ocaml-0.4.4.tar.gz 473064 BLAKE2B 47f401c89107e24c07d3076a5e8dbb2b383270abc138470b78680347cc3d5759227a9a56956217324adf354996d9ea018926dc887cba2cd7ea2fdc43293dbaaa SHA512 3ff319f3563d1fb465cbd4151713c5c1bb3f3ce1f8a2c0d6f938eb99d91844f97cce7c127c52fe970f0f095ced513b3cc440837540631e76037d1882b6d9b820
+DIST gapi-ocaml-0.4.5.tar.gz 788573 BLAKE2B 7c1b422b94c5c8f42cb3994624d7b31089a6662bd1e14c08a542320e7104d660ebf9bf3ace7d6068920a6a1ab67a11dfc237de0b5f81205130b015aa89ee76eb SHA512 3bc282cc316c8c76852404e427e046c44a644f74df8b5278c62e6d0a2df44af37e478841435e9ef919af7a94b23e8e937e0448d34ded9e07f48025546131ee28
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.5.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.5.ebuild
new file mode 100644
index 000000000000..6bd44fca60de
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=[ocamlopt?]
+ dev-ml/cryptokit:=[ocamlopt?]
+ dev-ml/yojson:=[ocamlopt?]
+ dev-ml/camlp-streams:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/cppo
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"