summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 16:16:33 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 16:16:33 +0100
commitc5f1cc041956aad443ce48fa53479b98c194ba0a (patch)
tree698181610235e71627d63b220afd476dade149f0 /dev-lua/lua-term
parentdev-lua/lua-term: update lua eclass ebuild (diff)
downloadgentoo-c5f1cc041956aad443ce48fa53479b98c194ba0a.tar.gz
gentoo-c5f1cc041956aad443ce48fa53479b98c194ba0a.tar.bz2
gentoo-c5f1cc041956aad443ce48fa53479b98c194ba0a.zip
dev-lua/lua-term: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-term')
-rw-r--r--dev-lua/lua-term/lua-term-0.7-r100.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-lua/lua-term/lua-term-0.7-r100.ebuild b/dev-lua/lua-term/lua-term-0.7-r100.ebuild
deleted file mode 100644
index 5ced1bbb4f1a..000000000000
--- a/dev-lua/lua-term/lua-term-0.7-r100.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-MY_PV="0.07"
-MY_PV_SO="1.0.1"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Terminal operations for Lua"
-HOMEPAGE="https://github.com/hoelzro/lua-term"
-SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O3//g' -i Makefile
-}
-
-lua_src_compile() {
- # Clean project to compile it for every lua slot
- emake clean
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CFLAGS=${CFLAGS} ${LDFLAGS} $(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}" all
-
- # Copy module to match the choosen LUA implementation
- cp "core.so.${MY_PV_SO}" "core-${ELUA}.so.${MY_PV_SO}" || die
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- # Use correct module for the choosen LUA implementation
- cp "core-${ELUA}.so.${MY_PV_SO}" "core.so.${MY_PV_SO}" || die
-
- local myemakeargs=(
- LUA_LIBDIR="${ED}/$(lua_get_cmod_dir)/term"
- LUA_SHARE="${ED}/$(lua_get_lmod_dir)/term"
- )
-
- emake "${myemakeargs[@]}" install
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-}