summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-01-04 02:22:57 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-04 02:22:57 +0100
commit44af3b70e3c8f9880d5bc6a1f1c8530ed6a3fde3 (patch)
tree2b2ee2d790e9cded973594814dd56b8640bb50d0 /dev-lua/lua-term
parentnet-wireless/aic8800: new package, add 1.0.3 (diff)
downloadgentoo-44af3b70e3c8f9880d5bc6a1f1c8530ed6a3fde3.tar.gz
gentoo-44af3b70e3c8f9880d5bc6a1f1c8530ed6a3fde3.tar.bz2
gentoo-44af3b70e3c8f9880d5bc6a1f1c8530ed6a3fde3.zip
dev-lua/lua-term: add 0.8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-term')
-rw-r--r--dev-lua/lua-term/Manifest1
-rw-r--r--dev-lua/lua-term/lua-term-0.8.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-lua/lua-term/Manifest b/dev-lua/lua-term/Manifest
index 47939a9931a0..7b7b7ef410e3 100644
--- a/dev-lua/lua-term/Manifest
+++ b/dev-lua/lua-term/Manifest
@@ -1 +1,2 @@
DIST lua-term-0.7.tar.gz 4365 BLAKE2B 8f4080d4cd3b620cb1f261d417744f112d42b776ab3f4cdb0e52d04b6d64fc4a1ddbd634570496c3bc12e6b10efe5af8025d1f124198ebb3946414679a65f7f4 SHA512 2046ba1861ff590c191bb651941c45eb8b6e9a1252b05e78daaeb31837ce1fc7da9ba124aec34dc7842fd304e945754c463ffd75941125ff952e911ba66efa31
+DIST lua-term-0.8.tar.gz 4838 BLAKE2B 690c9e7b7e831d69d0a2626c69721ca53fe9026e4885af50925942ebce1ffa44b2242cbe91b4ddcccfa2fbd56b3eeb3eeb8aa5014d1689ed1b6d2e184da785aa SHA512 115d2696f244945d876ae97ea6e9f3be0ea0e19ec7e057cbc047d3189482fca0e21ff68fee79e5d24257496cf51f507451f408f0b0a952ff707ffe0eedc36866
diff --git a/dev-lua/lua-term/lua-term-0.8.ebuild b/dev-lua/lua-term/lua-term-0.8.ebuild
new file mode 100644
index 000000000000..15fe641ac5fc
--- /dev/null
+++ b/dev-lua/lua-term/lua-term-0.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PV="0.08"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Terminal operations for Lua"
+HOMEPAGE="https://github.com/hoelzro/lua-term"
+SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O3//g' -i Makefile
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CFLAGS=${CFLAGS} -fPIC ${LDFLAGS} $(lua_get_CFLAGS)"
+ )
+
+ emake "${myemakeargs[@]}" all
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ LUA_LIBDIR="${ED}/$(lua_get_cmod_dir)/term"
+ LUA_SHARE="${ED}/$(lua_get_lmod_dir)/term"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}