summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-01 08:53:35 +0100
committerSam James <sam@gentoo.org>2023-09-01 08:53:35 +0100
commitfbef733e3d9830a54563a44ae4dda03cdb78d1ae (patch)
treeb91972389b9e3f06b0e1fab8fbb71a4b636c454b /dev-libs
parentRevert "app-crypt/openpgp-keys-wireshark: initial import" (diff)
downloadgentoo-fbef733e3d9830a54563a44ae4dda03cdb78d1ae.tar.gz
gentoo-fbef733e3d9830a54563a44ae4dda03cdb78d1ae.tar.bz2
gentoo-fbef733e3d9830a54563a44ae4dda03cdb78d1ae.zip
dev-libs/libnl: fix build w/ USE=utils
Closes: https://bugs.gentoo.org/913383 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/libnl-3.8.0.ebuild3
-rw-r--r--dev-libs/libnl/libnl-9999.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-libs/libnl/libnl-3.8.0.ebuild b/dev-libs/libnl/libnl-3.8.0.ebuild
index a9a0476e5ca6..3929eab8e2d2 100644
--- a/dev-libs/libnl/libnl-3.8.0.ebuild
+++ b/dev-libs/libnl/libnl-3.8.0.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+# Make sure to test USE=utils on bumps and update MULTILIB_WRAPPED_HEADERS if needed
+
DISTUTILS_EXT=1
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
@@ -53,6 +55,7 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libnl3/netlink/cli/exp.h
/usr/include/libnl3/netlink/cli/link.h
/usr/include/libnl3/netlink/cli/mdb.h
+ /usr/include/libnl3/netlink/cli/nh.h
/usr/include/libnl3/netlink/cli/neigh.h
/usr/include/libnl3/netlink/cli/qdisc.h
/usr/include/libnl3/netlink/cli/route.h
diff --git a/dev-libs/libnl/libnl-9999.ebuild b/dev-libs/libnl/libnl-9999.ebuild
index f60d51139ecb..f2b9a23648ad 100644
--- a/dev-libs/libnl/libnl-9999.ebuild
+++ b/dev-libs/libnl/libnl-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+# Make sure to test USE=utils on bumps and update MULTILIB_WRAPPED_HEADERS if needed
+
DISTUTILS_EXT=1
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
@@ -53,6 +55,7 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libnl3/netlink/cli/exp.h
/usr/include/libnl3/netlink/cli/link.h
/usr/include/libnl3/netlink/cli/mdb.h
+ /usr/include/libnl3/netlink/cli/nh.h
/usr/include/libnl3/netlink/cli/neigh.h
/usr/include/libnl3/netlink/cli/qdisc.h
/usr/include/libnl3/netlink/cli/route.h