summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-22 16:55:10 +0000
committerSam James <sam@gentoo.org>2023-02-22 16:55:27 +0000
commite4d54e3c92a16651a92d0f367ba580e53098b668 (patch)
tree2b3e1a22a2cbe0412bc3c7d86996d85f763be235 /dev-libs
parentapp-admin/terraform: add 1.3.9 (diff)
downloadgentoo-e4d54e3c92a16651a92d0f367ba580e53098b668.tar.gz
gentoo-e4d54e3c92a16651a92d0f367ba580e53098b668.tar.bz2
gentoo-e4d54e3c92a16651a92d0f367ba580e53098b668.zip
dev-libs/rinutils: add 0.10.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rinutils/Manifest1
-rw-r--r--dev-libs/rinutils/rinutils-0.10.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/rinutils/Manifest b/dev-libs/rinutils/Manifest
index 172d0bc8efc7..dcc12943719f 100644
--- a/dev-libs/rinutils/Manifest
+++ b/dev-libs/rinutils/Manifest
@@ -1 +1,2 @@
DIST rinutils-0.10.0.tar.xz 17268 BLAKE2B 2c651b70295d10690ca76bf1349ce83728cd5398fe4babf821ee6a0d61d4c7d107c6c68595e19a841fb5baaa0057237357b3917acd61c02599781bf0252fd512 SHA512 d3780b34b4eda4658f65cf7555553430441fcd45fb2d4fdba22a8f48c0df09c6c0a4e9543262c797c0602e2f9bace2d3f41514ae202ee13183286c9fb1f38677
+DIST rinutils-0.10.1.tar.xz 19160 BLAKE2B afefc834e3968d9cc32e3cb3368c1aadedaa90adf9f6e95c0d11367ce5ec9f2960b73685f55293aaa4c9aecb31b8a26a235f4d0aae60ffd4eaa8d229e31e84d6 SHA512 e743ee02258132830e7fd4436c1e6bfda33cdd90835978ad5a233562f85848274846ba0b46a1402cd70054da4dffba78f7e3d6e8fe484d97c569b4f9c7459abd
diff --git a/dev-libs/rinutils/rinutils-0.10.1.ebuild b/dev-libs/rinutils/rinutils-0.10.1.ebuild
new file mode 100644
index 000000000000..2f63f9dbebd7
--- /dev/null
+++ b/dev-libs/rinutils/rinutils-0.10.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Set of C headers containing macros and static functions"
+HOMEPAGE="https://www.shlomifish.org/open-source/projects/ https://github.com/shlomif/rinutils"
+SRC_URI="https://github.com/shlomif/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_APPLYING_RPATH=OFF
+ -DWITH_TEST_SUITE=OFF # tests require perl
+ )
+
+ cmake_src_configure
+}