summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-19 15:39:11 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-19 15:39:11 +0200
commite0a5cf65863b94b8b98be02ed824eb92200f24a3 (patch)
tree7de5e6cc49deea2e3f04b348e792599610f0a9b7 /dev-libs
parentnet-misc/netkit-rsh: keyword ~arm64 (diff)
downloadgentoo-e0a5cf65863b94b8b98be02ed824eb92200f24a3.tar.gz
gentoo-e0a5cf65863b94b8b98be02ed824eb92200f24a3.tar.bz2
gentoo-e0a5cf65863b94b8b98be02ed824eb92200f24a3.zip
dev-libs/libinput: Version bump to 1.7.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.7.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 17717083fd98..51c895a801fe 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -2,3 +2,4 @@ DIST libinput-1.6.2.tar.xz 929180 SHA256 96fc0e0b24a96042b16e561201979dfa4a3f00a
DIST libinput-1.6.3.tar.xz 926740 SHA256 74da2798728e79c3aedfffa268d8fe811c3766ca3708309c0dc45502be137da1 SHA512 be1ab191b5605943d6f46a5fee7af9ecba83ab30ba3d38b6ec136980f2183f6dcb5aaf048aa81a096c4f51b6de05bebc83b4ffa29a0574752062a994f377aa5f WHIRLPOOL e90739d84b87c9a419bbbb636cb535bebd51cacc18d215f87f952af41bb67a747de0c4c732cd83bd4d23143b3d6d4090a09e150d41f05edfb260e26a08688778
DIST libinput-1.7.1.tar.xz 922432 SHA256 2e56bc5bbf7d202dd94e1a5673489ce86fe10b1d4b5145948e9ba15f053247c1 SHA512 ee477fbbe2042ffeff70a960caf97e914d28c916af495765071a0184f442fa503d461bc34b87dc3dd62ef1bfd3e921ddc6fc065f8089d16d81c037d53d677352 WHIRLPOOL dcdd5bc6f80044ea1118b7e8647a1f43147f5bf4a3d3391d859e1c65a91d30c2f1a68a8553a1131caaf379bb4505f9061a601f61eb1103c6896de7b9d7adb9cf
DIST libinput-1.7.2.tar.xz 923720 SHA256 0b1e5a6c106ccc609ccececd9e33e6b27c8b01fc7457ddb4c1dd266e780d6bc2 SHA512 cdbd2994e954aac9538fe907c275e6e23e2bed0e9c4c65f19591bdcdbf5074131c72b92e87de87c03f75a991fcdb7f568b491a12f00031c4eba11082ca44d69f WHIRLPOOL 869623f2ef8da44627f28552f86583a6e6927f4966489f1c59d4b7c5061983d58744be5ea162a97e07e4a79495f56a728faaa273f8d45a8a2ee242819769aae8
+DIST libinput-1.7.3.tar.xz 922464 SHA256 096d612d2711f0caa2de544976ff3729e6233511ab373808644cc2dd5affcb1d SHA512 2262dc56d213a4d3ea765e870af200e2c336a166baa1bbdf5205e3ce70faefc777429ba09563c5dd79feb5442f53abc84e04a0f32a06bb622d6e120bb8ad152b WHIRLPOOL 06ea9038f7b3127b3238fc863b1ec862647a08b1ab4956fcfd433093dc3c68585ba3b166515370681ed158a48ce6a5670c6b8dcb6d536af25f8bda2c84c74286
diff --git a/dev-libs/libinput/libinput-1.7.3.ebuild b/dev-libs/libinput/libinput-1.7.3.ebuild
new file mode 100644
index 000000000000..f3060d7878ca
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.7.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ default
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}