summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-04-09 10:51:55 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-04-09 10:53:03 -0500
commit9e5188b0d75f8e3aa4ba331fea893fdc03004713 (patch)
treebf71bb1dd1d4d29c09d754096620f7dc24394627 /dev-libs
parentdev-ruby/dry-types: add missing test dependency (diff)
downloadgentoo-9e5188b0d75f8e3aa4ba331fea893fdc03004713.tar.gz
gentoo-9e5188b0d75f8e3aa4ba331fea893fdc03004713.tar.bz2
gentoo-9e5188b0d75f8e3aa4ba331fea893fdc03004713.zip
dev-libs/dotconf: add 1.4.1
Closes: https://bugs.gentoo.org/928975 Closes: https://bugs.gentoo.org/928980 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dotconf/Manifest1
-rw-r--r--dev-libs/dotconf/dotconf-1.4.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/dotconf/Manifest b/dev-libs/dotconf/Manifest
index 533738c497da..b3784a209d53 100644
--- a/dev-libs/dotconf/Manifest
+++ b/dev-libs/dotconf/Manifest
@@ -1,2 +1,3 @@
DIST dotconf-1.3.tar.gz 333301 BLAKE2B df3f4c9bc4539ed5b21bd4d6059bd911bb319d9dbe4f48c6d45c34559eaaa646abea847f6d0b35678c12d9b5e89e2f112047557d458be608215d76bb50af004c SHA512 ced0e66f70d11a309e77add1bfac1da8e85dcbe193633bd4bd1ae4bfd043b66880406e93ec18327b8c5d3de8d4bfc5278db6e5cb39b030ee1dabfa1ce267a98e
+DIST dotconf-1.4.1.tar.gz 46565 BLAKE2B 8eb7508b6ca13f0f4cc2ca0c1d889ce7801c3d60d826078a23b68807f1c2fa38fed4e638ac4b1a2ddf9c1e204293e57acce29bbd5cf3d6fd12abb140b6cb0d3e SHA512 a6cada8621295b268d4b4fd85bc0c207e78324c9e84754ead2fdf6c1598ec8bdf626f9c24e66063d921c95d73e83b50ab50416a9b4c9a7a631392552ec46f55a
DIST dotconf-1.4.tar.gz 46560 BLAKE2B b5cedb5c810bb0757f1137e9a70883cf7794bf2f57a2e368fcd8ec516ca28d1b7f05978d7d0845f672ad88291eb718fd148b8016dc4f81f0f2bdb0af236532db SHA512 7e40dbe5b8dca618ef007612ffc40930fb84c3394c2f1e0f341817fc9979c1e2b3204b35bbf102ad9d6851661464e61bcf2fe208048a323bf69e79eb27332781
diff --git a/dev-libs/dotconf/dotconf-1.4.1.ebuild b/dev-libs/dotconf/dotconf-1.4.1.ebuild
new file mode 100644
index 000000000000..36d47ae81583
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="https://github.com/williamh/dotconf"
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/williamh/dotconf.git"
+else
+ SRC_URI="https://github.com/williamh/dotconf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=dev-build/autoconf-2.58"
+
+src_configure() {
+ eautoreconf
+ econf --disable-static
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}