summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-01-17 17:59:05 +0000
committerMike Gilbert <floppym@gentoo.org>2020-01-17 14:08:54 -0500
commit93dcea5824ae860475bf12d4f454da1f0f17a8bb (patch)
tree1249bfbbf6c7bf0361b8a317ec83a870445bc94b /dev-libs
parentdev-cpp/glog: Drop alpha. Fix dependencies. (diff)
downloadgentoo-93dcea5824ae860475bf12d4f454da1f0f17a8bb.tar.gz
gentoo-93dcea5824ae860475bf12d4f454da1f0f17a8bb.tar.bz2
gentoo-93dcea5824ae860475bf12d4f454da1f0f17a8bb.zip
dev-libs/marisa: Delete old version (0.2.4).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/marisa/Manifest1
-rw-r--r--dev-libs/marisa/files/marisa-0.2.4-python.patch15
-rw-r--r--dev-libs/marisa/marisa-0.2.4.ebuild86
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-libs/marisa/Manifest b/dev-libs/marisa/Manifest
index 816030c1f7ac..1a55c59ef89b 100644
--- a/dev-libs/marisa/Manifest
+++ b/dev-libs/marisa/Manifest
@@ -1,2 +1 @@
-DIST marisa-0.2.4.tar.gz 502552 BLAKE2B aa8e6ce11c35db41f386d1c5d3ffdf56a940f298e10a7f6b1fa14cb80c27c9c4af1d4d61c58786f96e9598effe26379127c69b8fe72b1ca561a44ee2b9cddc61 SHA512 71aee3ae034d1ce725d986bef43472d61bd64f0af3ccda01bb019cce03f0872629b6a1b305e717056bef06e036372323b2a67e5dc69705d6a74e028b5e2553e4
DIST marisa-0.2.5.tar.gz 167434 BLAKE2B 2b88e9f0060529c2180400290bb975a946666f58f77f7604cf3ea8ae0ad7e44e0d95e18c8911d9630561b9593eb2ec123b5c67d6d195dab480d86fe431ce2531 SHA512 62975a2dacd2a1072c990cd490f866cd5483c069c94a4706baf3ffc21ec43991583a8ef8721c3b841617b0654cbb894698c19759ff12b8887b6fd28939dfb547
diff --git a/dev-libs/marisa/files/marisa-0.2.4-python.patch b/dev-libs/marisa/files/marisa-0.2.4-python.patch
deleted file mode 100644
index fba0e016d475..000000000000
--- a/dev-libs/marisa/files/marisa-0.2.4-python.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- bindings/python/setup.py 2011-05-14 07:20:52.000000000 +0200
-+++ bindings/python/setup.py 2013-08-02 17:04:16.423771834 +0200
-@@ -1,8 +1,10 @@
- from distutils.core import setup, Extension
-
- marisa_module = Extension("_marisa",
-- sources=["marisa-swig_wrap.cxx", "marisa-swig.cxx"],
-- libraries=["marisa"])
-+ sources=["marisa-swig.i", "marisa-swig.cxx"],
-+ swig_opts=["-c++"],
-+ libraries=["marisa"], library_dirs=["../../lib/.libs"],
-+ include_dirs=["../../lib"])
-
- setup(name = "marisa",
- ext_modules = [marisa_module],
diff --git a/dev-libs/marisa/marisa-0.2.4.ebuild b/dev-libs/marisa/marisa-0.2.4.ebuild
deleted file mode 100644
index 94066df3c186..000000000000
--- a/dev-libs/marisa/marisa-0.2.4.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Matching Algorithm with Recursively Implemented StorAge"
-HOMEPAGE="https://github.com/s-yata/marisa-trie https://code.google.com/archive/p/marisa-trie/"
-SRC_URI="https://marisa-trie.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc ppc64 ~sparc x86"
-IUSE="python doc static-libs cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_sse4a cpu_flags_x86_popcnt"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )"
-
-# implied by --enable switches
-REQUIRED_USE="
- cpu_flags_x86_popcnt? ( cpu_flags_x86_sse3 )
- cpu_flags_x86_sse4a? ( cpu_flags_x86_popcnt cpu_flags_x86_sse3 )
- cpu_flags_x86_sse4_2? ( cpu_flags_x86_popcnt cpu_flags_x86_sse4_1 )
- cpu_flags_x86_sse4_1? ( cpu_flags_x86_ssse3 )
- cpu_flags_x86_ssse3? ( cpu_flags_x86_sse3 )
- cpu_flags_x86_sse3? ( cpu_flags_x86_sse2 )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python.patch"
- if use python; then
- pushd bindings/python || die
- ln -sf ../marisa-swig.i marisa-swig.i || die
- ln -sf ../marisa-swig.h marisa-swig.h || die
- ln -sf ../marisa-swig.cxx marisa-swig.cxx || die
- distutils-r1_src_prepare
- popd || die
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable cpu_flags_x86_sse3 sse3)
- $(use_enable cpu_flags_x86_ssse3 ssse3)
- $(use_enable cpu_flags_x86_sse4_1 sse4.1)
- $(use_enable cpu_flags_x86_sse4_2 sse4.2)
- # sse4 is just an alias to sse4.2
- $(use_enable cpu_flags_x86_sse4a sse4a)
- $(use_enable cpu_flags_x86_popcnt popcnt)
- )
- econf "${myeconfargs[@]}"
-
- if use python; then
- pushd bindings/python || die
- distutils-r1_src_configure
- popd || die
- fi
-}
-
-src_compile() {
- default
- if use python; then
- pushd bindings/python || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_install() {
- default
- if use python; then
- pushd bindings/python || die
- distutils-r1_src_install
- popd || die
- fi
- use doc && dohtml docs/readme.en.html
- prune_libtool_files
-}