summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@mobilityhouse.com>2017-12-03 15:12:06 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-12-07 21:15:03 +1100
commit6ee0574f47cdce4a6fded9e5243db4aab857502b (patch)
tree206534cc7798711906fc8121a6380f3c870d5b02 /dev-libs
parentsys-apps/apparmor: Added systemd unit. (diff)
downloadgentoo-6ee0574f47cdce4a6fded9e5243db4aab857502b.tar.gz
gentoo-6ee0574f47cdce4a6fded9e5243db4aab857502b.tar.bz2
gentoo-6ee0574f47cdce4a6fded9e5243db4aab857502b.zip
dev-libs/libuev: Simple event loop for Linux
libuev is a simple event loop in the style of the more established libevent, libev and the venerable Xt(3) event loop. The u (micro) in the name refers to both the small feature set and the small size overhead impact of the library. Experienced developers may appreciate that libuEv is built on top of modern Linux APIs: epoll, timerfd and signalfd. Note however, a certain amount of care is needed when dealing with APIs that employ signalfd. Libuev is required for net-ftp/uftpd (see bug https://bugs.gentoo.org/639564). Closes: https://bugs.gentoo.org/639630 Closes: https://github.com/gentoo/gentoo/pull/6423 Package-Manager: Portage-2.3.13, Repoman-2.3.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libuev/Manifest1
-rw-r--r--dev-libs/libuev/libuev-2.1.0.ebuild22
-rw-r--r--dev-libs/libuev/metadata.xml20
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libuev/Manifest b/dev-libs/libuev/Manifest
new file mode 100644
index 000000000000..56cc5b76b113
--- /dev/null
+++ b/dev-libs/libuev/Manifest
@@ -0,0 +1 @@
+DIST libuev-2.1.0.tar.xz 247388 BLAKE2B e2934fb79e32bf61e22a7c8fcdd6371f089c5e8a4f5b3039c10c90abd852d08c5612f7b871ef705afdca68857a270dfd133a1436cd9f49876e0bf47b903e6328 SHA512 82bd68c75f015284d3757886720d1a0e5689cf71b40b896410e5e4e952761fe05b090a33e0787f632afa7726567667e4dbbbc6270129828656953ded6d28d02b
diff --git a/dev-libs/libuev/libuev-2.1.0.ebuild b/dev-libs/libuev/libuev-2.1.0.ebuild
new file mode 100644
index 000000000000..661b7402fb61
--- /dev/null
+++ b/dev-libs/libuev/libuev-2.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libuev"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install(){
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libuev/metadata.xml b/dev-libs/libuev/metadata.xml
new file mode 100644
index 000000000000..55df3087918b
--- /dev/null
+++ b/dev-libs/libuev/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ libuEv is a simple event loop in the style of the more established
+ libevent, libev and the venerable Xt(3) event loop. The u (micro) in the
+ name refers to both the small feature set and the small size overhead
+ impact of the library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">troglobit/libuev</remote-id>
+ </upstream>
+</pkgmetadata>