summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2023-02-07 22:12:43 -0500
committerSam James <sam@gentoo.org>2023-02-22 16:14:07 +0000
commit4e41fc8570ce676461d46ffae31a62d97a5f59da (patch)
tree9c32560a3b6b1bbf8e3daf0cb1119fdcf824b53f /dev-libs
parentdev-util/hip: Fix rocclr hsa.h include bug for 5.1.3 (diff)
downloadgentoo-4e41fc8570ce676461d46ffae31a62d97a5f59da.tar.gz
gentoo-4e41fc8570ce676461d46ffae31a62d97a5f59da.tar.bz2
gentoo-4e41fc8570ce676461d46ffae31a62d97a5f59da.zip
dev-libs/rapidjson: don't force C++11
dev-cpp/gtest-1.13.0 now requires building with C++14 or later. Remove -std=c++11 and, if not overridden in CXXFLAGS, use the compiler default. For 9999, explicitly pass RAPIDJSON_BUILD_CXX17=ON, which supports that cmake option. Closes: https://bugs.gentoo.org/893466 Closes: https://github.com/gentoo/gentoo/pull/29479 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild3
-rw-r--r--dev-libs/rapidjson/rapidjson-9999.ebuild4
2 files changed, 5 insertions, 2 deletions
diff --git a/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild b/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
index a58044c99310..73b3f54b7a78 100644
--- a/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
+++ b/dev-libs/rapidjson/rapidjson-1.1.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -44,6 +44,7 @@ src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="${EPREFIX}/usr/share/doc/${PF}"
-DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+ -DRAPIDJSON_BUILD_CXX11=OFF # latest gtest requires C++14 or later
-DRAPIDJSON_BUILD_DOC=$(usex doc)
-DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
-DRAPIDJSON_BUILD_TESTS=$(usex test)
diff --git a/dev-libs/rapidjson/rapidjson-9999.ebuild b/dev-libs/rapidjson/rapidjson-9999.ebuild
index c13c44dc56c8..a003c49ec84e 100644
--- a/dev-libs/rapidjson/rapidjson-9999.ebuild
+++ b/dev-libs/rapidjson/rapidjson-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,6 +45,8 @@ src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="${EPREFIX}/usr/share/doc/${PF}"
-DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+ -DRAPIDJSON_BUILD_CXX11=OFF # latest gtest requires C++14 or later
+ -DRAPIDJSON_BUILD_CXX17=ON
-DRAPIDJSON_BUILD_DOC=$(usex doc)
-DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
-DRAPIDJSON_BUILD_TESTS=$(usex test)