summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-20 09:10:19 +0100
committerSam James <sam@gentoo.org>2024-05-20 09:10:52 +0100
commitcb65f4903f9b72a0ac51b6192762d659009baf4d (patch)
treedee19fb09ffabbef0b6c1309e02d1e7c294e8b42 /dev-libs/mimalloc/mimalloc-2.1.6.ebuild
parentdev-libs/mimalloc: conditionally add -latomic (diff)
downloadgentoo-cb65f4903f9b72a0ac51b6192762d659009baf4d.tar.gz
gentoo-cb65f4903f9b72a0ac51b6192762d659009baf4d.tar.bz2
gentoo-cb65f4903f9b72a0ac51b6192762d659009baf4d.zip
dev-libs/mimalloc: add 2.1.6
Includes a note to cleanup the libatomic hack in the next release. Bug: https://bugs.gentoo.org/923177 Bug: https://bugs.gentoo.org/931778 Closes: https://bugs.gentoo.org/930519 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.1.6.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.1.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.1.6.ebuild b/dev-libs/mimalloc/mimalloc-2.1.6.ebuild
new file mode 100644
index 000000000000..164388f44adf
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+IUSE="hardened test valgrind"
+RESTRICT="!test? ( test )"
+
+DEPEND="valgrind? ( dev-debug/valgrind )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ -DMI_TRACK_VALGRIND=$(usex valgrind)
+ -DMI_LIBC_MUSL=$(usex elibc_musl)
+ )
+
+ # XXX: Should be able to clean this up after 2.1.6
+ # https://github.com/microsoft/mimalloc/pull/898
+ #
+ # Bug #923177, #931778: append -latomic if it is available
+ test-flags-CCLD "-latomic" &>/dev/null &&
+ mycmakeargs+=( -DMI_USE_LIBATOMIC=ON )
+
+ cmake-multilib_src_configure
+}