summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-09-09 02:06:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-25 10:02:12 +0300
commit8c764adb5174651fd591a757a41f8864e8189095 (patch)
treecb23689ba858ad46f482c0ca1875177a0a149a3e /dev-libs/libx86emu
parentapp-text/sablotron: cleanup, rename patches (diff)
downloadgentoo-8c764adb5174651fd591a757a41f8864e8189095.tar.gz
gentoo-8c764adb5174651fd591a757a41f8864e8189095.tar.bz2
gentoo-8c764adb5174651fd591a757a41f8864e8189095.zip
dev-libs/libx86emu: add 3.5
Migrate to EAPI 8, update HOMEPAGE, SRC_URI and LICENSE. Closes: https://bugs.gentoo.org/686358 Closes: https://bugs.gentoo.org/723038 Closes: https://bugs.gentoo.org/834364 Closes: https://bugs.gentoo.org/879077 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32695 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs/libx86emu')
-rw-r--r--dev-libs/libx86emu/Manifest1
-rw-r--r--dev-libs/libx86emu/libx86emu-3.5.ebuild33
-rw-r--r--dev-libs/libx86emu/metadata.xml5
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libx86emu/Manifest b/dev-libs/libx86emu/Manifest
index df95413d8a44..5d5926c5b067 100644
--- a/dev-libs/libx86emu/Manifest
+++ b/dev-libs/libx86emu/Manifest
@@ -1 +1,2 @@
DIST libx86emu-1.1-9.8.src.rpm 59517 BLAKE2B 6ae5b7792b9b67b93d12e9908e9941417e4149ed6289e0d02b23710ae4295d74aae806d85b0a0aa719eee6d63725b161dd8870d92b5352383a0beee5ce7827c9 SHA512 cb44306bb76feb47d46f1f3dd92cc6bf694dcc2c42d191fd9ff9f0b68744aeb25e99b29336e5ffe67e9a3d02c51d56690429b892d7fd26438dcc1d6603e18bcb
+DIST libx86emu-3.5.tar.gz 144969 BLAKE2B 3bba65ca6b42e92ad578a1bdacc94b5aad1f38f51d1e1fde1db65590db9611823a9e750675feb9c20fc7706e19181fe334e127a9c861159cea03aa5ea33d90a7 SHA512 079a8b5a7166802cd9bf781436dccc36a064c7e05c199bb41cc4d225e43afad4cc99654b3cb58389f7f806ffa625b5d793468064fdd9fa758ae0415496b18a9e
diff --git a/dev-libs/libx86emu/libx86emu-3.5.ebuild b/dev-libs/libx86emu/libx86emu-3.5.ebuild
new file mode 100644
index 000000000000..f4c40aa7a9ab
--- /dev/null
+++ b/dev-libs/libx86emu/libx86emu-3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A library for emulating x86"
+HOMEPAGE="https://github.com/wfeldt/libx86emu"
+SRC_URI="https://github.com/wfeldt/libx86emu/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ echo "${PV}" > VERSION || die
+ rm -fr git2log || die
+}
+
+src_compile() {
+ emake shared CC=$(tc-getCC) CFLAGS="${CFLAGS} -fPIC -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ emake test CC=$(tc-getCC) CFLAGS="${CFLAGS} -fPIC -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc README.md
+}
diff --git a/dev-libs/libx86emu/metadata.xml b/dev-libs/libx86emu/metadata.xml
index 85e4ed814fa2..8c19e870e06d 100644
--- a/dev-libs/libx86emu/metadata.xml
+++ b/dev-libs/libx86emu/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">wfeldt/libx86emu</remote-id>
+ </upstream>
</pkgmetadata>