summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-14 22:44:49 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-14 22:45:21 -0400
commit3fdeedbf1470cf53f07cb7f9c89e240628864905 (patch)
treef4b9670daa40a7aa3836d383b6b4e1f15d10ad06 /dev-libs/libwacom
parentdev-lang/ghc: update bootstrap binary (diff)
downloadgentoo-3fdeedbf1470cf53f07cb7f9c89e240628864905.tar.gz
gentoo-3fdeedbf1470cf53f07cb7f9c89e240628864905.tar.bz2
gentoo-3fdeedbf1470cf53f07cb7f9c89e240628864905.zip
dev-libs/libwacom: Version bump to 2.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libwacom')
-rw-r--r--dev-libs/libwacom/Manifest1
-rw-r--r--dev-libs/libwacom/libwacom-2.5.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/libwacom/Manifest b/dev-libs/libwacom/Manifest
index b4df5b316abd..71cbe6ece893 100644
--- a/dev-libs/libwacom/Manifest
+++ b/dev-libs/libwacom/Manifest
@@ -1 +1,2 @@
DIST libwacom-2.4.0.tar.xz 108812 BLAKE2B 18f41cd052b18c652c61062948355b4738afe57db344749055492cc6853bcbe3048c582a72318891727ec0fb01a7799f4c80c544b37b51c9246f98e5ae3fef1b SHA512 c67b8a81e9f4285a4e6f422b29e9b8b3677e3fc45e5190fd2b95ad361e5ef35e124b7d78bcf2bb9d7b7183525a6be9916b3038714c42c9ef405a1075750465f3
+DIST libwacom-2.5.0.tar.xz 109284 BLAKE2B cb9443aba276694eb64c6073488746ff4aff75ed77f334425d2f391a591f0a6cf222ef2124b6533ca7f2ca8e5eef36cd335026a87afabc12d912918ac1f930ed SHA512 62d181a5f4ce1335cd72623b7e82d5d44b9a11c08ec2ef4a98fd815fe2e1f814f42c909c2977e1b1ce803f04bac43414577830ff3724643fcecaf37113d098cf
diff --git a/dev-libs/libwacom/libwacom-2.5.0.ebuild b/dev-libs/libwacom/libwacom-2.5.0.ebuild
new file mode 100644
index 000000000000..ae8e4a1f6c57
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-2.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/9" # libwacom SONAME
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libgudev:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/python-libevdev[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pyudev[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Don't call systemd daemon-reload in the test suite
+ sed -i -e '/daemon-reload/d' test/test_udev_rules.py || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ -Dudev-dir=$(get_udevdir)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}