summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:59:56 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:23 +0100
commit44e012aedea0cefce1428df235ad30b5f25ce5ab (patch)
treecd75721b99f4fa95298dd53a7fa741fe055d75d8 /dev-libs/libuninum
parentdev-libs/libugpio: drop 0.0.7 (diff)
downloadgentoo-44e012aedea0cefce1428df235ad30b5f25ce5ab.tar.gz
gentoo-44e012aedea0cefce1428df235ad30b5f25ce5ab.tar.bz2
gentoo-44e012aedea0cefce1428df235ad30b5f25ce5ab.zip
dev-libs/libuninum: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/libuninum')
-rw-r--r--dev-libs/libuninum/libuninum-2.7-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libuninum/libuninum-2.7-r1.ebuild b/dev-libs/libuninum/libuninum-2.7-r1.ebuild
new file mode 100644
index 000000000000..0307915cebf4
--- /dev/null
+++ b/dev-libs/libuninum/libuninum-2.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A library for converting unicode strings to numbers and vice versa"
+HOMEPAGE="https://billposer.org/Software/libuninum.html"
+SRC_URI="https://billposer.org/Software/Downloads/${P}.tar.bz2"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2 GPL-2+ LGPL-2 LGPL-2.1"
+SLOT="0"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}