summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2016-07-17 15:09:29 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-08-04 21:10:12 -0400
commita390b6011ea0586d18850c8e7f4a03f5285247eb (patch)
tree2ddbea551df135f5ac925a4ac05058f12d0161ef /dev-libs/libprelude/files
parentdev-perl/Email-Simple: Rm excess test deps on dev-perl/Test-Pod{,-Coverage} (diff)
downloadgentoo-a390b6011ea0586d18850c8e7f4a03f5285247eb.tar.gz
gentoo-a390b6011ea0586d18850c8e7f4a03f5285247eb.tar.bz2
gentoo-a390b6011ea0586d18850c8e7f4a03f5285247eb.zip
dev-libs/libprelude: New package
Libprelude is a library that guarantees secure connections between all sensors and the Prelude Manager. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=583126
Diffstat (limited to 'dev-libs/libprelude/files')
-rw-r--r--dev-libs/libprelude/files/libprelude-3.0.0-perl-hardening.patch14
-rw-r--r--dev-libs/libprelude/files/libprelude-3.0.0-ruby-configure.patch14
-rw-r--r--dev-libs/libprelude/files/libprelude-3.0.0-ruby-m4.patch20
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libprelude/files/libprelude-3.0.0-perl-hardening.patch b/dev-libs/libprelude/files/libprelude-3.0.0-perl-hardening.patch
new file mode 100644
index 000000000000..df77899c82fa
--- /dev/null
+++ b/dev-libs/libprelude/files/libprelude-3.0.0-perl-hardening.patch
@@ -0,0 +1,14 @@
+When : when building perl bindings. Without this patch, it does not take care of LDFLAGS.
+Why : It is required if you want to customize your own LDFLAGS, example : for hardening
+Upstream : https://www.prelude-siem.org/issues/761 It should be added in the next version of Prelude.
+--- a/bindings/perl/Makefile.PL.in
++++ b/bindings/perl/Makefile.PL.in
+@@ -27,7 +27,7 @@
+ my %attributs = (NAME => 'Prelude',
+ INC => '-I@top_builddir@ -I@top_builddir@/src/include -I@top_srcdir@/src/include -I@top_builddir@/src/libprelude-error -I@top_srcdir@/bindings/c++/include',
+ LIBS => ["-L@top_builddir@/src/.libs -lprelude -L@top_builddir@/bindings/c++/.libs -lpreludecpp", "-L$ENV{LIBDIR} -lprelude @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
+- LDDLFLAGS => "-L@top_builddir@/src/.libs $Config{lddlflags}");
++ LDDLFLAGS => "-L@top_builddir@/src/.libs $Config{lddlflags} @LDFLAGS@,-rpath");
+
+ if ( abs_path("@top_srcdir@") ne abs_path("@top_builddir@") ) {
+ foreach my $filename ( qw/Prelude.cxx Prelude.pm/ ) {
diff --git a/dev-libs/libprelude/files/libprelude-3.0.0-ruby-configure.patch b/dev-libs/libprelude/files/libprelude-3.0.0-ruby-configure.patch
new file mode 100644
index 000000000000..fc09beace223
--- /dev/null
+++ b/dev-libs/libprelude/files/libprelude-3.0.0-ruby-configure.patch
@@ -0,0 +1,14 @@
+--- a/configure.in
++++ b/configure.in
+@@ -525,9 +525,9 @@
+ dnl * Ruby support *
+ dnl **************************************************
+
+-
+-AM_PATH_RUBY(,with_ruby=yes, with_ruby=no)
++AC_ARG_WITH(ruby, AC_HELP_STRING(--with-ruby@<:@=PATH@:>@, Enable support for ruby binding @<:@default=auto@:>@),,with_ruby=no)
+ if test x$with_ruby != xno; then
++ AM_PATH_RUBY(,with_ruby=yes, with_ruby=no)
+ RUBY_ARCHDIR=`$RUBY -e 'require "rbconfig.rb"; puts RbConfig::expand("\$(archdir)")'`
+ RUBY_LIBRUBYARG=`$RUBY -e 'require "rbconfig.rb"; puts RbConfig::expand("\$(LIBRUBYARG)")'`
+
diff --git a/dev-libs/libprelude/files/libprelude-3.0.0-ruby-m4.patch b/dev-libs/libprelude/files/libprelude-3.0.0-ruby-m4.patch
new file mode 100644
index 000000000000..b02555afb65f
--- /dev/null
+++ b/dev-libs/libprelude/files/libprelude-3.0.0-ruby-m4.patch
@@ -0,0 +1,20 @@
+When : when building ruby bindings, it can not find ruby versin so configure will never enable ruby support
+Why : It is required if you want to use libprelude with ruby
+Upstream : https://www.prelude-siem.org/issues/759 It should be added in the next version of Prelude.
+--- a/m4/am_path_ruby.m4
++++ b/m4/am_path_ruby.m4
+@@ -96,11 +96,11 @@
+ dnl (shared libraries)
+ AC_CACHE_CHECK([for $am_display_RUBY extension module directory],
+ [am_cv_ruby_rbexecdir],
+- [am_cv_ruby_rbexecdir=`$RUBY -rrbconfig -e "drive = File::PATH_SEPARATOR == ';' ? /\A\w:/ : /\A/; prefix = Regexp.new('\\A' + Regexp.quote(RbConfig::CONFIG[['prefix']])); \\$prefix = RbConfig::CONFIG[['prefix']].sub(drive, ''); \\$sitearchdir = RbConfig::CONFIG[['sitearchdir']].sub(prefix, '\\$(prefix)').sub(drive, ''); print \\$sitearchdir;" 2>/dev/null || echo "${RUBY_EXEC_PREFIX}/local/lib/site_ruby/${RUBY_VERSION}/${RUBY_PLATFORM}"`])
++ [am_cv_ruby_rbexecdir=`$RUBY -r rbconfig -e "print RbConfig::CONFIG[['vendorarchdir']]"`])
+ AC_SUBST([rbexecdir], [$am_cv_ruby_rbexecdir])
+
+- RUBY_INCLUDES=`$RUBY -r rbconfig -e 'if RbConfig::CONFIG[["archdir"]] then print " -I" + RbConfig::CONFIG[["archdir"]] end
+- if RbConfig::CONFIG[["rubyhdrdir"]] then print " -I" + RbConfig::CONFIG[["rubyhdrdir"]] end'`
++ RUBY_VER=`$RUBY -rrbconfig -e "print RbConfig::CONFIG[['ruby_pc']]" | sed 's/.pc//g'`
++ RUBY_INCLUDES=`pkg-config $RUBY_VER --cflags`
+ AC_SUBST([RUBY_INCLUDES])
+
+ dnl pkgrbexecdir -- $(rbexecdir)/$(PACKAGE)