summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-08-21 18:12:33 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-08-21 18:21:53 +0200
commitcb9276553be734e5a100e2706a0e89ec4057a516 (patch)
treed954b1f206c25edc1d258aadde401447fd5dca8e /dev-libs/libfilezilla/libfilezilla-0.31.1.ebuild
parentkde-misc/basket: Update HOMEPAGE, reflecting repo move to kde.org (diff)
downloadgentoo-cb9276553be734e5a100e2706a0e89ec4057a516.tar.gz
gentoo-cb9276553be734e5a100e2706a0e89ec4057a516.tar.bz2
gentoo-cb9276553be734e5a100e2706a0e89ec4057a516.zip
dev-libs/libfilezilla: 0.31.1 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-libs/libfilezilla/libfilezilla-0.31.1.ebuild')
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.31.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/libfilezilla-0.31.1.ebuild b/dev-libs/libfilezilla/libfilezilla-0.31.1.ebuild
new file mode 100644
index 000000000000..0f53a3a78253
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.31.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/16" # libfilezilla.so version
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/nettle:0=
+ >=net-libs/gnutls-3.5.7:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_configure() {
+ if use ppc || use arm || use hppa; then
+ # bug 727652
+ append-libs -latomic
+ fi
+
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}