summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-21 19:38:24 +0100
committerSam James <sam@gentoo.org>2022-04-21 19:49:35 +0100
commit4266f0306163b5e6b6566023a645a64a82767ea8 (patch)
tree3731ef764c100d87680cbd651a1a1f65f07f69aa /dev-libs/libaio
parentx11-base/xorg-server: fix build with GCC 12 (diff)
downloadgentoo-4266f0306163b5e6b6566023a645a64a82767ea8.tar.gz
gentoo-4266f0306163b5e6b6566023a645a64a82767ea8.tar.bz2
gentoo-4266f0306163b5e6b6566023a645a64a82767ea8.zip
dev-libs/libaio: add 0.3.113
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libaio')
-rw-r--r--dev-libs/libaio/Manifest1
-rw-r--r--dev-libs/libaio/files/libaio-0.3.113-respect-LDFLAGS.patch12
-rw-r--r--dev-libs/libaio/libaio-0.3.113.ebuild89
-rw-r--r--dev-libs/libaio/libaio-9999.ebuild13
4 files changed, 109 insertions, 6 deletions
diff --git a/dev-libs/libaio/Manifest b/dev-libs/libaio/Manifest
index e956615f88e3..4e17deb166b4 100644
--- a/dev-libs/libaio/Manifest
+++ b/dev-libs/libaio/Manifest
@@ -1 +1,2 @@
DIST libaio-0.3.112.tar.gz 46977 BLAKE2B 088f3b195a65bdc97ae2318e47af17c65259ed3208dca7bfef93c81a800602085e5b2078dbd436c740be316d0ebd923a1b3b7c0808257e2e7c7fb0f7ae1e0dba SHA512 5f984529c9f747a6c82f1e4457fc0832bb1fc299ae6e700f2ac5a8ea7b9bfc6ea1e75809728cc115a020cff6685ed1f4e38c6aeacc1ea98dfccce04dd19dafaa
+DIST libaio-0.3.113.tar.gz 49980 BLAKE2B 2379c88670310b36942563d10f29dfcba0f49391952ffe7fe18b0c917f33ef610405fe13297d1dbb34b7ad1d3066d4a32587a7fb20babba2f264cfc2ab289e57 SHA512 65c30a102433bf8386581b03fc706d84bd341be249fbdee11a032b237a7b239e8c27413504fef15e2797b1acd67f752526637005889590ecb380e2e120ab0b71
diff --git a/dev-libs/libaio/files/libaio-0.3.113-respect-LDFLAGS.patch b/dev-libs/libaio/files/libaio-0.3.113-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..f9ac2037ff91
--- /dev/null
+++ b/dev-libs/libaio/files/libaio-0.3.113-respect-LDFLAGS.patch
@@ -0,0 +1,12 @@
+We need to place LDFLAGS earlier to ensure e.g. as-needed works correctly.
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -56,7 +56,7 @@ libaio.a: $(libaio_objs)
+
+ $(libname): $(libaio_sobjs) libaio.map
+ $(CC) $(CFLAGS) -c struct_offsets.c
+- $(CC) $(SO_CFLAGS) -Wl,--version-script=libaio.map -Wl,-soname=$(soname) -o $@ $(libaio_sobjs) $(LINK_FLAGS)
++ $(CC) $(SO_CFLAGS) $(LINK_FLAGS) -Wl,--version-script=libaio.map -Wl,-soname=$(soname) -o $@ $(libaio_sobjs)
+
+ install: $(all_targets)
+ install -D -m 644 libaio.h $(includedir)/libaio.h
diff --git a/dev-libs/libaio/libaio-0.3.113.ebuild b/dev-libs/libaio/libaio-0.3.113.ebuild
new file mode 100644
index 000000000000..55cac17c1de4
--- /dev/null
+++ b/dev-libs/libaio/libaio-0.3.113.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs flag-o-matic usr-ldscript
+
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE="https://pagure.io/libaio"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://pagure.io/libaio.git"
+else
+ SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+ # Has test failure on abi_x86_32 which needs investigating
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.112-cppflags.patch
+ "${FILESDIR}"/${PN}-0.3.113-respect-LDFLAGS.patch
+)
+
+src_prepare() {
+ default
+
+ local sed_args=(
+ -e "/^prefix=/s:/usr:${EPREFIX}/usr:"
+ -e '/^libdir=/s:lib$:$(ABI_LIBDIR):'
+ -e 's:-Werror ::'
+ )
+ if ! use static-libs; then
+ sed_args+=( -e '/\tinstall .*\/libaio.a/d' )
+ # Tests require the static library to be built.
+ use test || sed_args+=( -e '/^all_targets +=/s/ libaio.a//' )
+ fi
+ sed -i "${sed_args[@]}" src/Makefile harness/Makefile Makefile || die
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ if use arm ; then
+ # When building for thumb, we can't allow frame pointers.
+ # http://crbug.com/464517
+ if $(tc-getCPP) ${CFLAGS} ${CPPFLAGS} - <<<$'#ifndef __thumb__\n#error\n#endif' >&/dev/null ; then
+ append-flags -fomit-frame-pointer
+ fi
+ fi
+}
+
+_emake() {
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ ABI_LIBDIR="$(get_libdir)" \
+ CFLAGS_WERROR= \
+ emake "$@"
+}
+
+multilib_src_compile() {
+ _emake
+}
+
+multilib_src_test() {
+ mkdir -p testdir || die
+
+ # 'make check' breaks with sandbox, 'make partcheck' works
+ _emake partcheck prefix="${S}/src" libdir="${S}/src"
+}
+
+multilib_src_install() {
+ _emake install DESTDIR="${D}"
+}
+
+multilib_src_install_all() {
+ doman man/*
+ dodoc ChangeLog TODO
+
+ # move to / for multipath-tools, bug #325355
+ gen_usr_ldscript -a aio
+
+ # This lib is a bare minimal shim on top of kernel syscalls.
+ export QA_DT_NEEDED=$(find "${ED}" -type f -name 'libaio.so.*' -printf '/%P\n')
+}
diff --git a/dev-libs/libaio/libaio-9999.ebuild b/dev-libs/libaio/libaio-9999.ebuild
index cd86a0c918f6..d649103522c5 100644
--- a/dev-libs/libaio/libaio-9999.ebuild
+++ b/dev-libs/libaio/libaio-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
inherit multilib-minimal toolchain-funcs flag-o-matic usr-ldscript
DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
HOMEPAGE="https://pagure.io/libaio"
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://pagure.io/libaio.git"
else
@@ -21,8 +21,7 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${PN}-0.3.112-cppflags.patch
- "${FILESDIR}"/${PN}-0.3.111-optional-werror.patch
- "${FILESDIR}"/${PN}-0.3.112-respect-LDFLAGS.patch
+ "${FILESDIR}"/${PN}-0.3.113-respect-LDFLAGS.patch
)
src_prepare() {
@@ -31,13 +30,14 @@ src_prepare() {
local sed_args=(
-e "/^prefix=/s:/usr:${EPREFIX}/usr:"
-e '/^libdir=/s:lib$:$(ABI_LIBDIR):'
+ -e 's:-Werror ::'
)
if ! use static-libs; then
sed_args+=( -e '/\tinstall .*\/libaio.a/d' )
# Tests require the static library to be built.
use test || sed_args+=( -e '/^all_targets +=/s/ libaio.a//' )
fi
- sed -i "${sed_args[@]}" src/Makefile Makefile || die
+ sed -i "${sed_args[@]}" src/Makefile harness/Makefile Makefile || die
multilib_copy_sources
}
@@ -67,6 +67,7 @@ multilib_src_compile() {
multilib_src_test() {
mkdir -p testdir || die
+
# 'make check' breaks with sandbox, 'make partcheck' works
_emake partcheck prefix="${S}/src" libdir="${S}/src"
}
@@ -79,7 +80,7 @@ multilib_src_install_all() {
doman man/*
dodoc ChangeLog TODO
- # move crap to / for multipath-tools #325355
+ # move to / for multipath-tools, bug #325355
gen_usr_ldscript -a aio
# This lib is a bare minimal shim on top of kernel syscalls.