summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-12-06 14:59:14 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-12-06 14:59:25 -0600
commitad13b0e1903543e7668ab42d063cb7e05d0df258 (patch)
tree09320f9090a7c553dd61ecd35861ccc3df2dabf2 /dev-libs/leatherman
parentsys-process/at: allow app-alternatives/lex, app-alternatives/yacc (diff)
downloadgentoo-ad13b0e1903543e7668ab42d063cb7e05d0df258.tar.gz
gentoo-ad13b0e1903543e7668ab42d063cb7e05d0df258.tar.bz2
gentoo-ad13b0e1903543e7668ab42d063cb7e05d0df258.zip
dev-libs/leatherman: drop 1.12.7
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.12.7.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index d75863cd5d02..eb4cf7a74506 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,3 +1,2 @@
-DIST leatherman-1.12.7.tar.gz 815838 BLAKE2B 21284f5128c9264b751011b1d68c6baf553037612cab39cc339920091ae42980f6c3920f5b339d4cba31a40b190fa73d779f45dcc30b78e866708c3178ac6699 SHA512 dd763bf89d8356aa00805817af7029ee77452a9210b6aded16ac1434f233fbba9b41014ab55a076773f50da6d16e1cffae50e2a23d1c4b336df9cc88c05ede56
DIST leatherman-1.12.8.tar.gz 815817 BLAKE2B b0844527a470c0e54983d49abc84a7331a07f3cac76919f56e58a01d60b794e422f3ef8342e046c483a83c428d2c80ff8e8d6b71375f45ddb03a5721e63c7aef SHA512 c6096a7c0e95fb43c6998f26e8f28157f46b78af4eaf2caaa1caae832d2f23aa7591e3a29a17f24bc9b993421645d37d44249fd8cae15a3d18b40d614acd23ad
DIST leatherman-1.12.9.tar.gz 816107 BLAKE2B 1c2e50767585a30da40fdacde0aa8655cefc2a41cadd24a7689be5da0afcbe8627293d37780442873907996f01401b46340a3d7be5d9b2a65b2f87191daca6c3 SHA512 e69f2b0c04a1cbd20e097abcc020e7b27fb74f168207fcbcffce9fd0edd1760acc75d5c5f645d3a798f106e129ce73e512f0c11699733475b290dfc876de0565
diff --git a/dev-libs/leatherman/leatherman-1.12.7.ebuild b/dev-libs/leatherman/leatherman-1.12.7.ebuild
deleted file mode 100644
index 06e7e264bf51..000000000000
--- a/dev-libs/leatherman/leatherman-1.12.7.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 sparc x86"
-IUSE="debug static-libs test"
-#RESTRICT="!test? ( test )"
-RESTRICT="test" # restricted til we don't need the shared_nowide patch
-
-RDEPEND="dev-libs/boost:=[nls]
- net-misc/curl"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/portage-sandbox-test-fix.patch
- "${FILESDIR}"/1.12.2-shared_nowide.patch
-)
-
-src_prepare() {
- sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- # vendored boost lib conflicts with boost 1.73 and above
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DLEATHERMAN_ENABLE_TESTING=$(usex test)
- # We depend on Boost with nls, so this is always true
- -DLEATHERMAN_USE_ICU=ON
-
- -DLEATHERMAN_SHARED=$(usex !static-libs)
- )
-
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- "${WORKDIR}/${P}"_build/bin/leatherman_test || die
-}